1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / LDAP Login Error

LDAP Login Error

2 posts, 0 answered
  1. Chen Yong
    Chen Yong avatar
    1 posts
    Registered:
    14 May 2009
    04 Jul 2011
    Link to this post
    Hi,

    I have configured the LDAP connections and able to see Authentication Provider dropdown list (options: Default, LdapUsers)

    However, when I tried to login using one of the Ldap users, I get the following error message:

    [NullReferenceException: Object reference not set to an instance of an object.]
       DynamicModule.ns.Wrapped_LdapMembershipProvider_c07addffeabe48e49c0bcf486175618f.GetUser(String userName) +421
       Telerik.Sitefinity.Security.SecurityManager.AuthenticateUser(String membershipProviderName, String userName, String password, Boolean persistent, User& user) +128
       Telerik.Sitefinity.Security.Web.UI.LoginForm.LoginForm_Authenticate(Object sender, AuthenticateEventArgs e) +240
       System.Web.UI.WebControls.Login.AttemptLogin() +166
       System.Web.UI.WebControls.Login.OnBubbleEvent(Object source, EventArgs e) +78
       System.Web.UI.Control.RaiseBubbleEvent(Object source, EventArgs args) +52
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3410
    

    I suppose the login is successful because when I purposely entered incorrect password, it shows me "Incorrect Username/Password Combination" instead.

    On top of that, I am not sure if I have correctly configured the LDAP connections because I don't see the LDAP users under "Administration > User Management > Users". Am I suppose to see the domain users here?

    I have followed the instructions at http://www.sitefinity.com/documentation/installation-and-administration-guide/system-settings/configuring-ldap-settings.aspx

  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    04 Jul 2011
    Link to this post
    Hello Chen Yong,

    You should see the LDAP provider under Administration >> Users as a separate tab ( provider). Please restart the application after LDAP has been configured. You can also take a look at this thread.
    It looks like the LDAP provider could not find the user you are trying to authenticate. You can try to create an instance of LdapMembershipProvider and call its GetUser( string username) method to see what would be returned from the query - you should get Telerik.Sitefinity.Security.Model.User object.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered