+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Master/detail display mode for custom content?

Master/detail display mode for custom content?

4 posts, 0 answered
  1. Darcy
    Darcy avatar
    10 posts
    Registered:
    28 Feb 2012
    27 Dec 2012
    Link to this post
    Hello. I followed the directions here:

    http://www.sitefinity.com/blogs/slavoingilizov/posts/slavo-ingilizovs-blog/2011/12/12/url_filtering_in_built-in_content_widgets

    And even verified I'm setting it correctly via the video but am still getting duplicate content. I have one difference though, I'm using a set of custom content we created but the options are still available. 

    Checking in the error log there is an error related to the custom content:

    Extended Properties
    ----------------------------------------
    ----------------------------------------
    Timestamp: 12/27/2012 9:19:21 PM

    Message: HandlingInstanceID: ebfc1d66-4b3c-4d3e-bd4a-b45ded0ae28a
    An exception of type 'System.ArgumentException' occurred and was caught.
    ------------------------------------------------------------------------
    12/27/2012 14:19:21
    Type : System.ArgumentException, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
    Message : Invalid property name "useOnlyUploadMode" for configuration element "AssetsFieldDefinitionElement".
    Source : 
    Help link : 
    ParamName : 
    Data : System.Collections.ListDictionaryInternal
    TargetSite : 
    Stack Trace : The stack trace is unavailable.
    Additional Info:

    TimeStamp : 12/27/2012 9:19:21 PM
    FullName : Telerik.Sitefinity.Utilities, Version=5.0.2500.0, Culture=neutral, 
    Requested URL : http://REDACTED/Sitefinity/Dialog/ContentViewEditDialog?ControlDefinitionName=Telerik.Sitefinity.DynamicTypes.Model.JobPostings.JobPostBackendDefinition&ViewName=Job postBackendEditView


    Category: ErrorLog

    Priority: 0

    EventId: 9010

    Severity: Warning

    Title:Enterprise Library Exception Handling

    Process Name: c:\windows\system32\inetsrv\w3wp.exe

    Thread Name: 

    Win32 ThreadId:8256

    Could they be related or is that a separate thing?


  2. Darcy
    Darcy avatar
    10 posts
    Registered:
    28 Feb 2012
    08 Jan 2013
    Link to this post
    So then... It seems like this is purely an issue for custom content. Just not implemented yet or maybe not even in the road map. Correct?
  3. Wagner
    Wagner avatar
    21 posts
    Registered:
    05 May 2011
    08 Jan 2013
    Link to this post

    Having a similar issue here in a different scenario. My custom module has this in the definitions file:

                //PDF
                var pdfField = new AssetsFieldDefinitionElement(mainSection.Fields)
                {
                    ID = "pdfField",
                    DataFieldName = "PDF",
                    UseOnlyUploadMode = true,
                    DisplayMode = FieldDisplayMode.Write,
                    Title = "PDF",
                    ResourceClassId = typeof(ArticlesResources).Name,
                    WorkMode = AssetsWorkMode.SingleDocument,
                    MaxFileSize = 0,
                    CssClass = "sfFormSeparator"
                };
                mainSection.Fields.Add(pdfField);


    And I get this error in the Sitefinity log:

    Type : System.ArgumentException, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
    Message : Invalid property name "useOnlyUploadMode" for configuration element "AssetsFieldDefinitionElement".
    Source : 
    Help link : 
    ParamName : 
    Data : System.Collections.ListDictionaryInternal
    TargetSite : 
    HResult : -2147024809
    Stack Trace : The stack trace is unavailable.

    And this error on my javascript debug console:


    Uncaught TypeError: Cannot read property 'constructor' of null ScriptResource.axd:634Object.getTypeScriptResource.axd:634Telerik.Sitefinity.Web.UI.FieldControls.FieldControlsBinder._registerFieldControlsTelerik.Web.UI.WebResource.axd:1061Telerik.Sitefinity.Web.UI.FieldControls.FieldControlsBinder.set_fieldControlIdsTelerik.Web.UI.WebResource.axd:1207Telerik.Sitefinity.Web.UI.ContentUI.Views.Backend.Detail.DetailFormView._handlePageLoadTelerik.Web.UI.WebResource.axd:2170(anonymous function)ScriptResource.axd:461(anonymous function)ScriptResource.axd:2044Sys.Observer.raiseEventScriptResource.axd:1153Sys._Application.raiseLoadScriptResource.axd:2617Sys._Application._doInitializeScriptResource.axd:2605(anonymous function)ScriptResource.axd:2501(anonymous function)

  4. Darcy
    Darcy avatar
    10 posts
    Registered:
    28 Feb 2012
    25 Apr 2013
    Link to this post
    Well it seems all we had to do was upgrade Sitefinity and the issue was resolved. Clearly a bug that they squashed.
4 posts, 0 answered