+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Max file size when uploading to image library

Max file size when uploading to image library

7 posts, 0 answered
  1. Jeff
    Jeff avatar
    118 posts
    Registered:
    08 Jul 2011
    19 Jun 2012
    Link to this post
    Is there a max file size when uploading to an image library in SF5? I'm trying to upload a 2MB file and it never finishes.

    Look all over and can't find an answer.
  2. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    19 Jun 2012
    Link to this post
    Hey Jeff,

    Under Administration >> Settings >> Advanced >> Libraries check the 'size of a chunk in bytes when upload media data' and also take a look at your web.config's MaxRequestLength.
  3. Jeff
    Jeff avatar
    118 posts
    Registered:
    08 Jul 2011
    26 Jun 2012
    Link to this post
    Still can't get this working. Size of chunk is 81920 and MaxRequestLength is 102400. I tried changing these values but it doesn't make a difference. I also found a post that suggested adding the following to the system.webServer section of the web.config but this didn't work either. The file is only 2MB. I'm using the default database storage provider. It never times out. I've let it sit for over an hour an it just never finishes.
    <security>
          <requestFiltering>
            <requestLimits maxAllowedContentLength="209715200" />
          </requestFiltering>
        </security>
  4. Jeff
    Jeff avatar
    118 posts
    Registered:
    08 Jul 2011
    28 Jun 2012
    Link to this post
    Anyone else have any ideas?
  5. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    29 Jun 2012
    Link to this post
    Hey Jeff,

    Just tested it with Sitefinity v5.0.2800 with the following settings in my web.config:
    <system.web>
      <httpRuntime
      maxRequestLength="102400" 
      requestValidationType="Telerik.Sitefinity.Security.Claims.CustomRequestValidator, Telerik.Sitefinity"
      />

    And the librariesConfig.config file containing the following:
    <?xml version="1.0" encoding="utf-8"?>
    <librariesConfig xmlns:config="urn:telerik:sitefinity:configuration" xmlns:type="urn:telerik:sitefinity:configuration:type" config:version="5.0.2800.0">
     </librariesConfig>

    (Size of chunk = 81920 is default, so doesn't show up in the librariesConfig.config)

    I've uploaded a 37.1Mb video, a 5.2Mb document, a 2.8Mb image and a 51.2Mb downloadable goods file - all without any problem.

    ---
    Have you tried setting your default storage provider to file-system to see if it 'hangs' in Sitefinity or 'hangs' on your sql ? If it still fails with filesystem as your default provider, a re-install of Silverlight will probably do the trick.

    If it works perfect with the filesystem as storage provider, you're probably need to dive into your sql configuration...

    Good luck!
  6. Taha Zouhair
    Taha Zouhair avatar
    10 posts
    Registered:
    22 Aug 2013
    24 Feb 2015 in reply to Jochem Bökkers
    Link to this post

    I'm having similar issues (404 when sending large files ~600MB mp4s) but I'm not sure what it is. On the test environment it works well but in production it fails although the settings are exactly the same. 

     

    Any ideas?

  7. Sabrie Nedzhip
    Sabrie Nedzhip avatar
    534 posts
    Registered:
    09 Dec 2016
    27 Feb 2015
    Link to this post
    Hi Taha Zouhair,

    Since the issue does not reproduce when you run the project locally, it seems that the issue might be related to your environment settings.

    Can you please try to temporarily comment out the rewrite rules in your web.config file, if any, and test the behavior again?

    In addition to this, I would suggest that you make some changes to you web.config file and then test the behavior again.

    1. Please configure sendTimeout in your web.config file in the <bindings> section:

    <bindings>
      <basicHttpBinding>
        <binding name="basicHttpBinding" maxReceivedMessageSize="2147483647" maxBufferSize="2147483647" sendTimeout="5:00:00">
          <securitymode="None"/>
        </binding>
      </basicHttpBinding>
    </bindings>

    You may also refer to the following KB article for more details on this. 
     
    2. For Sitefinity versions 7.x, can you please also try to set the maxQueryStringLenght under the <configuration>/<system.web> section in your web.config file for example to 3000000:

    <system.web>
       <httpRuntime maxRequestLength="102400" maxUrlLength="102400" maxQueryStringLength="3000000" requestValidationType="Telerik.Sitefinity.Security.Claims.CustomRequestValidator, Telerik.Sitefinity" />

    You may also try to increase the executionTimeout in your web.config file under the same section - <configuration>/<system.web> section:

    <system.web>
    <httpRuntime executionTimeout="43200" maxRequestLength="102400" maxUrlLength="102400" maxQueryStringLength="3000000" requestValidationType="Telerik.Sitefinity.Security.Claims.CustomRequestValidator, Telerik.Sitefinity" />

    Furthermore, I have also found the following articles over internet about the file upload limit in IIS which you may find useful:

    http://www.webtrenches.com/post.cfm/iis7-file-upload-size-limits
    http://ajaxuploader.com/large-file-upload-iis-asp-net.htm

    Regards,
    Sabrie Nedzhip
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
7 posts, 0 answered