+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Module Builder and Widget Templates

Module Builder and Widget Templates

6 posts, 0 answered
  1. Darren
    Darren avatar
    4 posts
    Registered:
    21 Oct 2009
    14 Jan 2012
    Link to this post
    Hi there,

    I have been working on a custom module built with module builder which works well.  The only problem I have encountered is with the widget templates for displaying the data.  There was a list and full content template created automatically, however if I attempt to make any new ones they simply do not save.  I get no error message they just dissapear.
    Do I have a problem with my install or is this a know issue?  HAs anyone else encountered this?
    Darren
  2. Kristian Smilenov
    Kristian Smilenov avatar
    32 posts
    Registered:
    18 Mar 2015
    16 Jan 2012
    Link to this post
    Hello Darren,

    Thank you for contacting us.

    We are aware of this problem, it was logged in the PITS under ( Widget templates for the custom content types cannot be created ) and is already resolved. The fix will be available in our internal release this week.

    If you have any other questions don't hesitate to contact me/us.

    Regards,
    Kristian Smilenov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Richard
    Richard avatar
    15 posts
    Registered:
    17 Aug 2012
    05 Mar 2012
    Link to this post
    Hi,

    I have downloaded 5.0, but I can't seem to be able to create a Widget Template for my Dynamic Module (Module Builder module). The module doesn't appear in the list of items to create. How do I go about selecting to create one for this module?

    Note this does work via the in-Page dialog (but not via the Widget Templates page), so it's not too much of a concern. Just a little confusing.

    Thanks,
    Rich
  4. Richard
    Richard avatar
    15 posts
    Registered:
    17 Aug 2012
    05 Mar 2012
    Link to this post
    Double post error.
  5. Stoimen Stoimenov
    Stoimen Stoimenov avatar
    60 posts
    Registered:
    11 Jul 2016
    06 Mar 2012
    Link to this post
    Hello Richard,

    We have worked really hard to improve widget templates for 5.0 release and we have done lots of testing to make sure they are working properly now. However I tried to reproduce your issue but I didn't experienced any problems. I tried in a new Sitefinity 5.0 install and after that I tried to upgrade a Sitefinity 4.4 project with several modules to Sitefinity 5.0 but again I was able to create widget templates from the page editor.

    Can you provide me with more detailed description how to reproduce the bug? Excuse me for the inconvenience.

    Kind regards,
    Stoimen Stoimenov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Antoine
    Antoine avatar
    45 posts
    Registered:
    13 Jul 2012
    01 Jun 2012
    Link to this post
    For anyone stuck on this in 4.4, I was able to assign a different template to a dynamic module widget by assigning the Guid of the template to the DefaultMasterTemplateKey value in Advanced Settings of the widget.

    To determine the Guid, view the Widget Templates page using Chrome.  Using the Network feature in the Chrome Developer tools, you can preview the response from the ControlTemplate service which will reveal the Guids of the various widget templates.
6 posts, 0 answered