1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Multiple controls with the same ID for ToolTip

Multiple controls with the same ID for ToolTip

2 posts, 0 answered
  1. Phil
    Phil avatar
    89 posts
    Registered:
    19 Oct 2010
    10 Nov 2010
    Link to this post
    • I can get the RadToolTip to work fine in a web page in my generic website, but am having difficulty getting it to work in the SF web site.  I am using SF 4.0 Beta 2.0
    • I am trying to use the RadToolTip in the SF Edit-A-Page screen.  This is what I do
      1. drag a Content Block to the design surface.
      1. enter some text in the text area
      1. go to Advanced, and enter myContentBlock in the ID property
      2. Save it
      3. drag the RadControls ToolTip to the design surface, and complete the following properties

    TargetControl

    myContentBlock

    Title

    my title

    Text

    my text

    1. Save it
    2. Preview page and I get error:  Multiple controls with the same ID 'C001' were found. FindControl requires that controls have unique IDs.
    3. So I go back to edite-a-page screen and
    4. I edit the ToolTip properties so that

    IsClientID = true

    1. Then when I preview the page, it does not error but the mouse over does not work - it does nothing.
    2. So I do this
    1. I get the exact name of the div that I will be mousing over
    1. So I go back to edite-a-page screen and
    1. I edit the ToolTip properties so that

    TargetControlID = the-exact-name-in-the-client

    1. I Preview the page and the mouse over does nothing

     

  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    12 Nov 2010
    Link to this post
    Hi Phillip,

    Thank you for the provided steps. I followed them with the RC candidate and I am not able to replicate the issue. Let me explain you how the RadToolTip can work together with ContentBlock Control.

    1.By default, RadToolTip assumes a server ID. If the ID is client-side, as in the case where an element is pure HTML and not a server control, then the IsClientID property should be set to True.

    2. The content block is displayed by Literal with ID - "contentHtml" which ID is not rendered.

    3. If you work with the UI you can set the RadToolTip only with the client ID which is generated by a div that wraps the ContentBlock text and its is randomly generated for instance
    T019236E9001_Col00
    <div id="" class="sf_colsIn sf_2cols_1in_75"><div class="sfContentBlock"> 


    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered