+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Navigation widget empty when selecting "all pages under particular page"

Navigation widget empty when selecting "all pages under particular page"

11 posts, 0 answered
  1. Ian
    Ian avatar
    75 posts
    Registered:
    25 Oct 2010
    18 Jan 2011
    Link to this post
    Hi
    I've added a navigation widget to a page with child pages.
    In the settings, I've chosen a vertical list, and show "All pages under particular page" and then selected the page in the page selector. The page is shown in the settings, but nothing shows up in the widget. All child pages have permissions set to view by anyone, but they do not even show up when logged in as admin.
    I've tried readding and adding the navigation widget, and get the same result.

    Any ideas?

    Thanks
    Ryan
  2. Sonya
    Sonya avatar
    205 posts
    Registered:
    09 Dec 2016
    19 Jan 2011
    Link to this post
    Hello Ryan,

    Unfortunately, I could not reproduce the problem locally.

    I tried the following steps:
    PageTest
               >Page1
               >Page2


    • Opened PageTest >add ‘Navigation’ widget
    • Clicked ‘Edit’ link
    • Selected ‘Verticalnavigation
    • Then set ‘PageTest’ from Select ‘All pages under particular page’
    • Clicked ‘Save
    • Page1 and Page2 was shown in the Navigation widget
    Let me know if I missed something.

    Can you please give us a complete set of steps and pre-conditions in order to reproduce the issue?

    Kind regards,
    Sonya
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Antoaneta
    Antoaneta avatar
    258 posts
    Registered:
    02 Nov 2015
    19 Jan 2011
    Link to this post
    Hello Ryan,

    What is the status of the pages? Are they published?

    If they are not, try to publish them and check again.
    Pages which are not published will not be displayed in the navigation.

    All the best,
    Antoaneta
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  4. Saeed
    Saeed avatar
    14 posts
    Registered:
    21 Jun 2011
    09 Jul 2011
    Link to this post
    Hi there,

    I noticed that, it happens when the parent page is group page!
  5. Sonya
    Sonya avatar
    205 posts
    Registered:
    09 Dec 2016
    13 Jul 2011
    Link to this post
    Hi Saeed,

    I still could not reproduce the problem locally (see attached video). Which Sitefinity version are you running?

    Kind regards,
    Sonya
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Saeed
    Saeed avatar
    14 posts
    Registered:
    21 Jun 2011
    13 Jul 2011
    Link to this post
    Hi Sonya,
    I saw the Video, and it seems it works fine on your machine!
    In my Case I've tried to Create an About Menu as "Grouping Menu" that will redirect to it's first child "Overview" but in Overview page It couldn't show the Menu Items under About Node!

    I'm using V4.1 Sp1, Maybe Its solved in Sp2?

    I also had a problem for showing pages under a page that Its Show in navigation was false, but had same problem there too!
  7. Sonya
    Sonya avatar
    205 posts
    Registered:
    09 Dec 2016
    13 Jul 2011
    Link to this post
    Hi Saeed,

    Can you make a short movie of the problem? Would you give us an access to the problematic website backend, so we will try to see what could be the problem. 

    All the best,
    Sonya
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  8. Saeed
    Saeed avatar
    14 posts
    Registered:
    21 Jun 2011
    13 Jul 2011
    Link to this post
    Ok, But I prefer to give you my local servers IP in private!
    Please send me an email, I'll reply access info!
  9. Sonya
    Sonya avatar
    205 posts
    Registered:
    09 Dec 2016
    13 Jul 2011
    Link to this post
    Hello Saeed,

    You can open a Bug Report and give us access to your project. 

    Best wishes,
    Sonya
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  10. Pavol Kokinda
    Pavol Kokinda avatar
    39 posts
    Registered:
    28 Sep 2012
    25 Feb 2013 in reply to Sonya
    Link to this post

    Hi Sonya,

    what is the status about the problem with navigation ? I prepare currently upgrade from version 3.7 SP4 to 5.4 and I encountered similar problem with vertical navigation.

    Regards,

    Pavol Kokinda

  11. Atanas Valchev
    Atanas Valchev avatar
    414 posts
    Registered:
    04 Jan 2016
    28 Feb 2013
    Link to this post
    Hello Pavol,

    We fixed a problem with the navigation in the hotfix 5.4 4010. Did you try it in this version? If you are experiencing a problem in 5.4 4010, please open a Bug Report so we can investigate it. 

    Kind regards,
    Atanas Valchev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
11 posts, 0 answered