+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / No endpoint listening at http://....../DefaultWorkflows/Any...

No endpoint listening at http://....../DefaultWorkflows/Any...

6 posts, 0 answered
  1. Viktoriya
    Viktoriya avatar
    20 posts
    Registered:
    29 Jul 2010
    16 Jun 2011
    Link to this post
    Hello everyone, 

    We've just pushed a website live and are getting the attached error when we are trying to create and publish blog posts.

    We don't have this issue in the staging evironment...

    Can anyone help? It's rather urgent!

    Thank you!!!

    Vix
  2. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    09 Dec 2016
    17 Jun 2011
    Link to this post
    Hi Viktoriya,

    We have introduced a new property (WorkflowBaseUrl) in Administration -> Settings -> Advanced -> System -> ServicePaths. You should set the base url to the domain name you are publicly viewing your website on, for example http://mydomain.com. The problem might come from the fact that the request from outside may come for one location but internally it is forwarded to another and then Sitefinity does not know where exactly the default workflows are. If setting the WorkflowBaseUrl does not help, please check with FireBug if the GET & PUT methods work properly when trying to publish a page, because the problem may be coming from request restrictions of IIS.
    You can try using a workaround which includes referencing the the host header in the hosts file e.g :
    127.0.0.1   domainname.com
    and also adding the host header with this IP to the configuration of the site in IIS. Make sure that you bind the correct IP address to your localhost not your domain if you are testing locally.
    I hope you find this information useful. If you need any further assistance with this issue, please do not hesitate to contact me.



    Regards,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Viktoriya
    Viktoriya avatar
    20 posts
    Registered:
    29 Jul 2010
    17 Jun 2011
    Link to this post
    Hi Boyan, 

    Thanks for your reply. We found the issue yesterday.
    It turned out that the .xamlx handler was not mapped on the server. 

    I still however followed your instructions about the setting of the WorkflowBaseUrl property.

    Thank you again.

    Viktoriya
  4. Paul
    Paul avatar
    18 posts
    Registered:
    14 Jan 2011
    30 May 2012
    Link to this post
    Hi

    We are experiencing a similar if not the same problem with our hosted aspwebhosting.com.au. We installed Sitefinity 4.4 on the server and finally managed to get the website running but not the backend.

    Every time we try to save any content/setting/action we get 500 Internal Server Error. We reckon it is the same problem but not in the same detailed manner we know it from our DEV environment.

    I tried to change the WorkFlowBaseURL but since I can not save any settings (maybe it is because it is a different problem after all) it does not accept it and throws error 500.

    So, I was wondering if we can set the WorkFlowBaseURL in a (config) file somewhere on the file system rather than in just the backend?

    Thanks for any help and clues.

    Regards


    ====================

    Update:
    I have found where the workflowbaseurl can be changed in the meantime:
    App_Data/Sitefinity/Configuration/SystemConfig.config

    The second last line should be workflowbaseurl.

    Cheers


    ==================================================

    Update on our case:

    Turns out that something with the server that aspwebhosting.com.au used for our Sitefinity environment was wrong. After they moved the whole project to a different server it was working.

    Also, make sure the URL you add to WorkflowBaseUrl is actually pointing to that server where it is hosted.

    Finally, also try adding the project URL and host server IP to the hosts file for it to make a reference to itself. This usually helps, too.
  5. Anh
    Anh avatar
    3 posts
    Registered:
    07 Apr 2014
    07 Apr 2014 in reply to Boyan Barnev
    Link to this post

    Hi,

     

    I having the same issue, but when i try to save changes I got a message saying that access to the path .../SystemConfig.config is denied . What would be a solution for this. 

     

    Thank you.

  6. Svetoslav Manchev
    Svetoslav Manchev avatar
    735 posts
    Registered:
    07 Dec 2016
    08 Apr 2014
    Link to this post
    Hi Anh,

    Most probably the  ASP.NET worker process does not have read/write permissions over App_Data and configuration files. Please grant the asp.net user account (or network service) with read/write permissions. You can do this from windows explorer if you have direct access to the server.

    Regards,
    Svetoslav Manchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
6 posts, 0 answered