+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Page Additional URLs with @ symbol don't redirect

Page Additional URLs with @ symbol don't redirect

3 posts, 1 answered
  1. Jacques
    Jacques avatar
    427 posts
    Registered:
    28 Jun 2007
    30 Jun
    Link to this post

    We don't know how this happened but we seem to have links pointing to our customer's site which have email addresses in them.

    We're trying to redirect these to the branch page but it's not working.

    URL Example: http://mysite.com/office/branch@mysite.com

    In the additional URLs section we added: 

    ~/office/branch@mysite.com

    And selected the option to redirect (301). But it doesn't work. 

    Is there a way that we can make this work? 

  2. Victor Leontyev
    Victor Leontyev avatar
    65 posts
    Registered:
    01 Jul 2014
    30 Jun in reply to Jacques
    Link to this post

    Hi Jacques
    You can create this redirect rule in you web.config

    <rule name="request with email /office/branch@mysite.com" stopProcessing="true">
        <match url="^office/[A-Z0-9._%+-]+@[A-Z0-9.-]+\.[A-Z]{2,4}$" />
        <action type="Redirect" url="office" />
    </rule>

    Answered
  3. Jacques
    Jacques avatar
    427 posts
    Registered:
    28 Jun 2007
    01 Jul in reply to Victor Leontyev
    Link to this post
    Thanks Victor that worked perfectly! 
3 posts, 1 answered