+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Parent page content instead of HTTP 404?

Parent page content instead of HTTP 404?

8 posts, 0 answered
  1. Anton Mernov
    Anton Mernov avatar
    110 posts
    Registered:
    03 Dec 2008
    07 Feb 2011
    Link to this post
    Hi there,

    I have created a page in Sitefinity with URL /test and with some content.
    When I browse this page from http://localhost:60876/test I can see my text. It's OK.

    When I try to browse non existing child page, for instance, http://localhost:60876/test/sub-test then it shows me the content of parent page. However, I expect to see HTTP 404 error.

    I'd like to ask two questions:
    1. Is it a bug or a new feature of Sitefinity 4?
    2. In case of new feature, is there a way to obtain programmatically the values after parent page?
    For example, on the parent page we have some widget and we have URL like this http://localhost:60876/test/sub-test/sub-test2. Of course, the child pages with URLs sub-test and sub-test2 do not exist, therefore the parent page should be loaded. In widget's code I would like to get values:

    var firstParam = someObject.Items[0]; //holds sub-test
    var secondParam = someObject.Items[1]; //holds sub-test2

    Is it possible?

    Thanks in advance,
    Anton.
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    09 Feb 2011
    Link to this post
    Hello Anton,

    This is a known bug of Sitefinity which we have logged for fixing.

    Best wishes,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Pavel
    Pavel avatar
    14 posts
    Registered:
    25 Sep 2007
    02 May 2011
    Link to this post
    This bug is still not fixed in Q1 release...
  4. GeorgePPetrov
    GeorgePPetrov avatar
    18 posts
    Registered:
    24 Sep 2012
    04 May 2011
    Link to this post
    Hi Anton,

    I added your issue to the bug.
    Since the PITS system was introduced lately, you can track in it the progress of the bug on this public link:
    http://www.telerik.com/support/pits.aspx#/public/sitefinity/4964

    As long your second question in your initial post, please let me know if you find some solution to it or is it still pending.

    Best wishes,
    GeorgePPetrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Doug Lubey
    Doug Lubey avatar
    31 posts
    Registered:
    17 Apr 2010
    22 Jan 2012
    Link to this post
    This issue says it has been correctted but it is not:
    PLEASE REFERENCE
    Please see links:
    1> http://www.sitefinity.com/devnet/forums/sitefinity-4-x/general-discussions/httphandler-not-working.aspx

    2> http://www.sitefinity.com/devnet/forums/sitefinity-4-x/bugs-issues/question-how-to-integrate-url-rerouting-with-sitefinity-virtual-folder-structure-version-4-3-1885-0.aspx

    3>http://www.sitefinity.com/devnet/forums/sitefinity-4-x/general-discussions/parent-page-content-instead-of-http-404.aspx

    The actual TroubleTicket
    http://www.telerik.com/support/pits.aspx#/public/sitefinity/4964



  6. GeorgePPetrov
    GeorgePPetrov avatar
    18 posts
    Registered:
    24 Sep 2012
    24 Jan 2012
    Link to this post
    Hello Doug,

    I checked with latest official release (4.4 from 2012 Jan 22) and saw the following behavior:

     
    /home              200 OK           - ordinary page used as parent
    /home/gp1        200 OK             - subpage of the parent page
    /homz               404             - wrong URL
    /home/z            Server error    - wrong URL after the parent page
    /home/gp1/z     Server error      - wrong URL after the child page
    /grouppage       200 OK           - group page
    /grouppage/z    404                - wrong URL under a group page
    /grouppage/subpage2     200 OK     - child page of a group page
    /grouppage/subpage2/z  Server error - wrong URL under a subpage

    I filled a critical bug for the above behavior - to have 404 instead of server error in above cases.

    Regards,
    GeorgePPetrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Eric
    Eric avatar
    147 posts
    Registered:
    12 Nov 2007
    26 Jan 2012
    Link to this post
    Is there a new PITS number? I searched for 404, but didn't see anything recent and the old PITS item is still resolved.
  8. GeorgePPetrov
    GeorgePPetrov avatar
    18 posts
    Registered:
    24 Sep 2012
    27 Jan 2012
    Link to this post
    Hi Eric,

    Thank you for contacting Telerik support. It was my fault, thanks to you I changed the visibility of the PITS issue to public, its number is 9506.

    Greetings,
    GeorgePPetrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
8 posts, 0 answered