+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Performance on Azure

Performance on Azure

6 posts, 0 answered
  1. Bil
    Bil avatar
    51 posts
    Registered:
    27 Aug 2012
    16 May 2015
    Link to this post

    Hi guys,

    I'm just starting to get our site up and running on Azure and finding some disappointing performance. 

    I have it running on an small (A1) service but every page was taking (almost exactly) 5 seconds to load. I've just created a basic site, we're using feather (so it's all MVC with a bootstrap master page). Simple pages with a few lorem ipsum text. Nothing to see here.

    I would have expected even on a small instance to be somewhat quick. I've even scaled it out to two instances to see if that helps and it didn't. The CPU (over the last 7 days) has never gone over 20% and averages around 2%. Same with the database.

    One of the bothersome things is that I have my domain registered with the product which is fine for the production system (mydomain.cloudapp.net) but you can't create a cloud service like dev.mydomain.cloudapp.net so I have this "sandbox" I stood up (to figure out some things like how feather will work) named mydomain-d.cloudapp.net and of course every few requests it tells me I'm running a trial version. This won't be a problem on the production site but I was hoping I could have created a non-prod site on Azure without the trial nag.

    Anyways, wondering what could be the cause of the bottlenecks with the pages or is the trial version actually have a 5 second load on every page (because it looks like thats the case). Yes, my data centre is in the same region as the cloud service, etc. and while it's only an A1 deploy I really can't believe I have to go to a medium or large just to get a little bit of performance when the pages contain nothing (yet).

    Thanks.

  2. Kaloyan
    Kaloyan avatar
    272 posts
    Registered:
    08 Dec 2016
    20 May 2015
    Link to this post
    Hi Bill,

    Trial message should not affect the overall performance. In order to prevent this message to appear you have to use your project on localhost or with the registered domain. In case you want to register additional sub-domains you can contact your account manager.

    Regards,
    Kaloyan
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  3. Bil
    Bil avatar
    51 posts
    Registered:
    27 Aug 2012
    21 May 2015 in reply to Kaloyan
    Link to this post

    Okay so if the trial part isn't affecting Azure performance what is? Looking through the Azure cloud service that Sitefinity deploys to I have two small (A1) instances deployed with a minimal site (5 pages). Visiting the home page this morning took 30-45 seconds to load and hitting each new page takes about 5 seconds. Once loaded it's fine but the initial load is unacceptable. There's nothing in Azure I can see to monitor the load or why it's happening and doesn't seem to be anything in Sitefinity to help me here. VM load hasn't been over 10% (with an average of about 1% over the past 24 hours). The only operation log messages were the deployments I did yesterday. Most of the settings on the cloud service are not configurable or non-existant, which I feel is because the supported SDK version is only at 2.2.

    This is frustrating because I have no visibility into what's going on with the service on Azure. If the site was running as a website I'd be able to see all kinds of information but with the Sitefinity cloud service there's nothing.

  4. Kaloyan
    Kaloyan avatar
    272 posts
    Registered:
    08 Dec 2016
    26 May 2015
    Link to this post
    Hello Bill,

    We are planning to update Azure SDK to version 2.6 for the upcoming 8.1 release. As for the performance problems that you are currently experiencing can you please provide a link to your website, so I can inspect the performance directly on your environment. In addition can you please tell what is the version of Sitefinity that you are currently using.

    Regards,
    Kaloyan
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  5. Bil
    Bil avatar
    51 posts
    Registered:
    27 Aug 2012
    26 May 2015 in reply to Kaloyan
    Link to this post

    Hi Kaloyn,

    I have a setup at http://dev.fortisalberta.com. This is running Sitefinity 8.0.5713.0 on Azure. We're using Feather with a custom ResourcePackage (just a modified copy of the Bootstrap one) with minimal pages right now as the IA isn't built out yet.

    On Azure the site is running on 2 small instances (A1, 1 core each instance, 1.75GB memory). The SQL database is running on the S0 tier with 10 DTUs assigned. Everything is located in the same data center (West US).

    Over the last 6 days the CPU averages about 2% so there's no load going on here (nobody is using the site) and I've got two endpoints monitoring the system (1 in Chicago and 1 in San Jose) that both respond without about 500ms. 

    However when a user visits the pages they seem to take about 4 seconds to load if it hasn't been visited recently (based on what I'm seeing in Fiddler).

    Thanks

  6. David
    David avatar
    3 posts
    Registered:
    14 Apr 2015
    24 Mar
    Link to this post

    For IIS 7.5....

     

    http://weblog.west-wind.com/posts/2013/Oct/02/Use-IIS-Application-Initialization-for-keeping-ASPNET-Apps-alive

6 posts, 0 answered