+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / "You are not authorized to 'View {0}' ('PageTemplates')."

"You are not authorized to 'View {0}' ('PageTemplates')."

9 posts, 0 answered
  1. Stacey
    Stacey avatar
    291 posts
    Registered:
    18 Oct 2012
    02 Dec 2010
    Link to this post
    I am playing around with setting roles to users to see what they do, but I keep running into an error when trying to view pages.

    "You are not authorized to 'View {0}' ('PageTemplates')."

    I first tried with the default settings meaning that I created a user and set them to be an Editor and BackEndUser role.  I logged in with the new user and saw that the menu was only showing the items that I should have access to.  If I click on Pages I get the authorization error.  I tried to access content -> news and that seemed to work.

    I then tried editing the permissions for the Editor and BackEndUser roles to allow view/modify writes to Page templates and Generic Content.

    Is there a specific combination that needs to happen or is this a bug?
  2. Alon Rotem
    Alon Rotem avatar
    26 posts
    Registered:
    29 Feb 2016
    05 Dec 2010
    Link to this post
    Hello Stacey,

    I could not reproduce your problem with our latest code version.
    Could you please provide additional information about the problem?

    Did you get the authorization error message for PageTemplates while clicking on the "Pages" menu link?
    Did you have any front-end pages saved in your system?
    Did you add any page templates to the system, apart from the default pre-existing ones?
    Did you change any of the default permissions in the system? For a specific page or a template?
    While being logged in as an Editor user, by default the Design/Page Templates menu item should not be accessible. Was that the case for you as well?

    Any additional information about any changes to the default state would also be very helpful.
    Thank you.

    Regards,
    Alon Rotem
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Stacey
    Stacey avatar
    291 posts
    Registered:
    18 Oct 2012
    06 Dec 2010
    Link to this post
    Did you get the authorization error message for PageTemplates while clicking on the "Pages" menu link? Yes
    Did you have any front-end pages saved in your system? Yes
    Did you add any page templates to the system, apart from the default pre-existing ones? Yes
    Did you change any of the default permissions in the system? For a specific page or a template? No
    While being logged in as an Editor user, by default the Design/Page Templates menu item should not be accessible. Was that the case for you as well? Yes

    I started from a fresh install, created a masterpage that contains a few contentplaceholders and then loaded it as a custom page template.  I then created a page based off the custom page template and added some content.  Next I created a user and set them as an editor and backenduser (left the permissions set as their defaults). 

    When I logged in as the new user I only see "Dashboard, Pages, Content" which seems correct to me.  If I click on the Pages link I receive the "You are not authorized to 'View {0}' ('PageTemplates')." error.
  4. Stacey
    Stacey avatar
    291 posts
    Registered:
    18 Oct 2012
    06 Dec 2010
    Link to this post
    I figured it out.  I took a look at the actual permission on the custom template and noticed everything is set to Administrator.  I looked at the default templates and notice that View and Create are set to all BackEndUsers.  I did the same for my template and can now access the pages area with the user who has Editor/BackEndUsers roles assigned.

    Should custom templates default to administrator only for all permissions?
  5. Alon Rotem
    Alon Rotem avatar
    26 posts
    Registered:
    29 Feb 2016
    08 Dec 2010
    Link to this post
    Hello Stacey,

    Thank you for providing additional information regarding your problem, which also helped me reproduce it here.The issue is divided into 2 symptoms which you have pointed out:

    When creating a new template in the system, its default permissions should be similar to the default permissions of the pre-existing templates.
    When accessing the pages which are based on a restricted template, the error message related to templates should not appear.

    I have logged those problems as a bug in our system, pending to be fixed.

    As a workaround, please apply your solution (i.e. if you add a template, make sure its permissions grant backend users the view and create actions).

    All the best,

    Alon Rotem
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Julien
    Julien avatar
    5 posts
    Registered:
    08 Dec 2010
    11 Jan 2011
    Link to this post
    Hello,

    We got the same problem and tried the workaround but it does not fix it.

    Will this issue be fixed with the official release?
    When the official release will be available?
  7. Alon Rotem
    Alon Rotem avatar
    26 posts
    Registered:
    29 Feb 2016
    19 Jan 2011
    Link to this post
    Hello Julien,

    This issue was fixed for version 4.0, officially released on 14th of January 2011. Fix details are as follows:

    1. All new templates in the system have the same default permissions: everyone can view, backend users can edit (also if the template is created by uploading a master page).

    2. If the user has no permissions for a template, they can still see/edit a page based on the template.

    Do you still have the problem using the latest build? If so, could you please provide additional information about your case?

    Thank you.

    Kind regards,
    Alon Rotem
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  8. Hemnath
    Hemnath avatar
    2 posts
    Registered:
    17 Nov 2014
    25 Mar 2015
    Link to this post

    Hi Team,

    We are getting the same error in Sitefinity 7.0 when we performed the Syncing from stage environment to our production environment. We tried to change the Permissions of the related Page templates to Everyone but the system is not allowing to make the changes. we were able to change it to back-end users or Administrators but we are getting the error in load balanced server which we used for syncing. once we login to the sitefinity/pages and open the page the error is getting resolved but it reoccurs when we deploy code to the production.

     Please advise. Thanks in advance

    Thanks,

    Hemnath

     

  9. Atanas Valchev
    Atanas Valchev avatar
    414 posts
    Registered:
    04 Jan 2016
    30 Mar 2015
    Link to this post
    Hello,

    Did you change the permissions on the source site before syncing? Permissions are not synced currently and it is hard to tell what caused the issue. You can move over the source database to the destination if this is the case or manually change the permissions. Furthermore, I would like to suggest opening a ticket to investigate this issue further.

    Regards,
    Atanas Valchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
9 posts, 0 answered