+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / RadEditor has issues when I...

RadEditor has issues when I...

37 posts, 0 answered
  1. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    13 Jan 2011
    Link to this post
    I'm also seeing in Firefox when using RC2 that if I open a GC contaner and make an edit, save, then go back into another GC container (or same, just opening the editor)...I lose my cursor.  If I click in the box and start typing I see text, but without the cursor I have no idea where I am in the editor, or even that it has focus.
  2. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    17 Jan 2011
    Link to this post
    Hi,

    Thanks Steve. I forwarded this to out front-end developers.

    Best wishes,
    Georgi
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. higgsy
    higgsy avatar
    336 posts
    Registered:
    05 Aug 2010
    17 Jan 2011
    Link to this post
    Gabe/Georgi,

    Did you want me to raise these issues or do you have them in hand.

    Regards,
    higgsy
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    18 Jan 2011
    Link to this post
    Hello ,

    We are going to check the issues you reported and see what can be done for the next SP.

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Antoine
    Antoine avatar
    45 posts
    Registered:
    13 Jul 2012
    27 Oct 2011
    Link to this post
    Start with:
    <div class="container">
    <h2>Test</h2>
    <ul>
        <li>Item 1</li>
        <li>Item 2</li>
    </ul>
    </div>

    In the Design view, cursor to the end of one of the list items and click enter to add a new item.  The <div> has become a <p>:
    <p class="container">
    <h2>Test</h2>
    <ul>
        <li>Item 1</li>
        <li></li>
        <li>Item 2</li>
    </ul>
    </p>

    Save the content, or switch between Design View and then back to HTML view.  The content that was originally in the <div> is not even contained within the <p> anymore:
    <p class="container">
    </p>
    <h2>Test</h2>
    <ul>
        <li>Item 1</li>
        <li></li>
        <li>Item 2</li>
    </ul>

    We are using the <div> elements because we have some less than trivial layouts that we are styling, but we still want users to be able to use the content editor to be able to add list items.  Is this possible?

    Thanks,
    Antoine
  6. Le Corbu
    Le Corbu avatar
    16 posts
    Registered:
    27 Apr 2006
    28 Oct 2011
    Link to this post
    Hi Antoine,

    funny, I had exactly the same problem yesterday.
    But unfortunately no solution yet (less funny).
    It seems that RadEditor doesn't like divs, even if you set NewLineMode to "Div" (but "Br" seems to be better than "p" in this case).
    Any idea from Telerik?
    Started playing around with editors styles, paragraphs and snippets.....

    Have a nice weekend!

    Udo
  7. debi
    debi avatar
    1 posts
    Registered:
    11 Dec 2009
    21 Aug 2013
    Link to this post
    Obviously, this is an old forum, but it's valid for our issues with the RadEditor. We currently have Sitefinity 5.1 and many of the issues described in this forum still exist. However, I have a new one to add. Whenever we use a an html5 <section></section> tag in the RadEditor, it works until the next person opens the RadEditor, which then the closing tag </section> completely disappears. We are using IE8 (I know, is outdated, but this is the standard installed version on our computers at our company). Can you reproduce the issue on your end?

37 posts, 0 answered
1 2