+1-888-365-2779
Try Now
More in this section

Search

19 posts, 0 answered
  1. Donna Stewart
    Donna Stewart avatar
    8 posts
    Registered:
    28 Apr 2009
    07 Nov 2012
    Link to this post
    Please, please, please bring back the forum-specific search!

    Thank you,
    Donna
  2. John S.
    John S. avatar
    126 posts
    Registered:
    09 Aug 2004
    08 Nov 2012
    Link to this post
    To add to the frustration here....

    I am trying to do a search on centering a video and am coming up with 68,300 hits. How am I supposed to narrow a search down to Sitefinity 5.x???
  3. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    08 Nov 2012
    Link to this post
    @Telerik

    http://www.sitefinity.com/devnet/forums/bugs-issues-/new-sitefinity-com-forum

    1 month without much improvements

    Trying to keep track of the issues, added new once on the bottom

    - slow 
    - no search within forums
    - no notification to answers in own post
    - Registration date changes when you change nickname
    - no indication on new or solved/answered threads 

    - No RadEditor tool to insert a link, only UnLink
    - Responsive Design takes Log-in away  www.marktold.com/screencast/sf_responsive_forum.swf
    - Lines on Editor when scrolling (at least in chrome on my machine)
    - Firefox editor unusable after attachment http://screencast.com/t/eohje1bbYE3H
      Answer area looks different on FF and Chrome anyhow. See attachments.
    - Scrollbars not touch userfriendly

    Are you skiing in denver or working on these issues?

    Markus


  4. Arno
    Arno avatar
    249 posts
    Registered:
    08 Sep 2010
    08 Nov 2012
    Link to this post
    Wow. I'm planning to work with the forums module soon. This is not very hopeful. I don't intend to loose my community due to a buggy forum...
  5. Svetoslav Petsov
    Svetoslav Petsov avatar
    456 posts
    Registered:
    24 Sep 2012
    12 Nov 2012
    Link to this post
    Hello guys,

    Thanks for the feedback.
     There is now a forum-specific search in the forums list. You can also filter the other search results on the results page (there is a list of filters to the left of the results). 
    The changing registration date is also fixed.

    Let me know if you have other problems with forums.

    Greetings,
    Svetoslav Petsov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    12 Nov 2012 in reply to Svetoslav Petsov
    Link to this post
    Dear Svetoslav

    I don't seem to get it. Sorry. How do I search the bugs/issues forum only?

    As for you asking if I have other problems with forum.

    Here is a list

    - slow 
    - no search within forums
    - no notification to answers in own post
    - Registration date changes when you change nickname
    - no indication on new or solved/answered threads 

    - No RadEditor tool to insert a link, only UnLink
    - Responsive Design takes Log-in away  www.marktold.com/screencast/sf_responsive_forum.swf
    - Lines on Editor when scrolling (at least in chrome on my machine)
    - Firefox editor unusable after attachment http://screencast.com/t/eohje1bbYE3H
      Answer area looks different on FF and Chrome anyhow. See attachments.
    - Scrollbars not touch userfriendly

    Markus
  7. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    12 Nov 2012 in reply to Markus
    Link to this post
    This one drives me mental
    "No RadEditor tool to insert a link, only UnLink"

    ...it's a 30 second backend settings fix! ...just add the tool, give me a login and I'll do it if nobody can be bothered

  8. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    12 Nov 2012
    Link to this post
    Just tried it out...it's such a terrible search...lucene blows, why doesn't telerik dogfood it internally.

    Go to the page: http://www.sitefinity.com/devnet/forums
    Search for this thread in partial: type in "Searc" (notice no H), hit enter
    Result: 1 entry returned, because someone typod search

    Retarded Lucene syntax to the "Rescue"
    Change the search to "Searc?" and hit enter...results appear

    Worst...search implementation...ever.

    IMO when it hits the SF backend it should auto-append those wildcards so it at least returns what the user would expect it to return.  Please show me a popular search engine that requires someone to use ? or * or some other character to flesh out their query.

    I also realize this is how it has always been...but it's always sucked :)
  9. MB
    MB avatar
    302 posts
    Registered:
    09 Jan 2005
    12 Nov 2012 in reply to Steve
    Link to this post
    If there is a forum-specific search, then it's not obvious to dummies like me.

    As far as I can see there is a search for ALL forums, but not for a specific forum.

    The bigger issue for me though, is the results returned.

    Invariably I get results for older versions (why would I want results for V2 at the top of the list?) and no obvious way to filter and/or sort these.
  10. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    13 Nov 2012 in reply to MB
    Link to this post
    @MB
    Am I glad that I am not the only one who does not seem to get it :-)

    @Telerik
    Nice try but no sale on this one.

    @Svetoslav
    Did you see my list of what else is not quite like I (and maybe others) would have it.
    Markus
  11. MB
    MB avatar
    302 posts
    Registered:
    09 Jan 2005
    13 Nov 2012 in reply to Steve
    Link to this post
    @Steve
    I'm pretty sure that the Lucene api is more than capable of providing a good search service.
    By default, I believe that it assumes an 'Alta-Vista' user syntax (which was always frustratingly pedantic) but (as I understand it) all of that can be configured.
    Not that I'm any expert on this, but I believe that Apache Solr is based on the Lucene api, and yet provides all of the features and experience expected of a modern full-text search engine.
  12. Svetoslav Petsov
    Svetoslav Petsov avatar
    456 posts
    Registered:
    24 Sep 2012
    15 Nov 2012
    Link to this post
    Hi guys,

      By "forums-specific" search I meant that we brought back the old search for the whole forums area. I'm sorry if I caused any misunderstanding.
     We have taken everything reported into consideration and we are investigating all the different issues and working on fixing them.

    Greetings,
    Svetoslav Petsov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  13. Richard Baugh
    Richard Baugh avatar
    201 posts
    Registered:
    22 Aug 2012
    15 Nov 2012 in reply to Svetoslav Petsov
    Link to this post
    On the old forums post, you could actually filter by an individual forum section by adding in the ID of the forum. It was a hack, but allowed us to filter the results a little more.
  14. MB
    MB avatar
    302 posts
    Registered:
    09 Jan 2005
    15 Nov 2012 in reply to Richard Baugh
    Link to this post
    @Richard Baugh
    Actually, I thought that the old 3.7 site did that automatically, when you used the search-bar available within each child forum.
    The main Telerik support forums are still running on a 3.7 site, and that is how they work... each forum has its own search-bar, and the '&fid=nnn' argument is automatically appended to the search.
  15. Richard Baugh
    Richard Baugh avatar
    201 posts
    Registered:
    22 Aug 2012
    16 Nov 2012 in reply to MB
    Link to this post
    Yes, you could go into an individual forum and do a search, but if you just wanted to search the entire 4.x+ forums you couldn't directly. If you went into a specific 4.x+ forum and did a search, it would then provide you with a link on the left side of the results to go up to the parent 4.x+ forum.

    I just grabbed the ID of this parent forum and would use it from the main search to save some of the extra clicks. You could also directly search by creating the search url yourself.
  16. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    20 Nov 2012
    Link to this post
    Hi all,

    I want to reasure you that  we are actively working on all the issues reported in this thread. The first changes are already vidible (we have improved the responsive design in the forums). Notifications issues will be resolved on Thursday (November 22).  Here is an ordered list of the next things which will be addressed:

    1) Improvments in the search area - add per forum group search. If possible add per forum search.
    2) Indication for answered threads in the forums list.

    I will notify you once we start working on the rest of the issues.

    Regards,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  17. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    22 Nov 2012 in reply to Radoslav Georgiev
    Link to this post
    Hey Radoslav,

    Awesome! Got my first 'a new thread has been submitted' email this morning :)
    Thanks for the great improvements!

    Jochem
  18. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    22 Nov 2012 in reply to Jochem Bökkers
    Link to this post
    @Radoslav
      Hey Rado, you probably are already aware, but...

    1) It's emailing me when I post a reply, which gets annoying, I don't need to be notified I just replied to someone

    2) Email has an "Unsibscribe" link (typo)...and is the same link as View All Posts.  The actual unsubscribe function is hidden weirdly behind "Email Subscription" which has an RSS icon (again, weirdly)
  19. MB
    MB avatar
    302 posts
    Registered:
    09 Jan 2005
    22 Nov 2012 in reply to Steve
    Link to this post
    @Steve - 2 steps forward, 1 step back - LOL.

    And on that subject... one of the (many) things annoying me has been that I need to log-in each time I start a new session, because the authentication cookie is apparently either being destroyed, discarded or ignored.

    I know it's trivial, but it just bugs me that none of this was apparently tested before changing a functioning tech-support site (albeit with some issues of its own) to a largely useless tech-support site, just to achieve the change in presentation.

    So anyway, this morning I need to log-in again to post, and just to run salt into it, there is now an extra pointless step introduced - a page with a [Telerik] button - between my request to login and the login page...
19 posts, 0 answered