Try Now
More in this section

Forums / General Discussions / Search Engine doesn't work

Search Engine doesn't work

2 posts, 0 answered
  1. Inna
    Inna avatar
    97 posts
    08 Jun 2012
    02 Nov 2012
    Link to this post
    hello, i'm on 5.2 version. Can't configure the search indexes. have multiple pdfs, ms word, etc - they are not being searched at all. the regular page are not searched either. i'm getting an empty search result page, although i followed your instructions on this page:  http://www.sitefinity.com/documentation/documentationarticles/user-guide/website-content/defining-search-indexes

    the page says:  The content of all published documents is indexed. The document formats
    that are supported for indexing are: TXT, HTML, RTF, DOCX, and PDF. 

    If you have created the index after you have published a document, you must reindex. You can do this on Search indexes page, by clicking the Actions link of the index and then clicking Reindex.

    i put the check next to the docs option, still doesn't work.
    also your instructions say:  When you select a content type for indexing, you must choose the default page that this type is published on.

    This is the page where the item opens by default. 

    What do you mean by "default"? i have multple pages with the content that needs to be indexed. there is no such thing as a default page. they are all unique pages. how do i make my content searchable?
  2. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    13 Aug 2007
    03 Nov 2012 in reply to Inna
    Link to this post
    Hey Inna,

    The 'default' page, is a page where you've dropped a search result widget on. That will be used as the standard-page to display the results. 

    After you've created the index (put the check boxes and pointed to the default pages) you need to click on more actions and select 'Reindex' as you pointed out.

    On the template, you need to drop a 'search box' widget and edit it. On the edit, you need to select the index you've just created.

    The reason for that extra step (the index selection) is because a website could have several search options, for instance just search documents, or products and one for the rest of the website.

2 posts, 0 answered