+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Session Timeout

Session Timeout

7 posts, 1 answered
  1. Wei
    Wei avatar
    6 posts
    Registered:
    23 Nov 2011
    23 Nov 2011
    Link to this post
    In Sitefinity Version 4.3, my session would time out if there was no activity 2 hours.

    i want change 2 hours to 30 minutes.

    i add this code in web.config .but it not work. does i make some mistakes?   or  how i can change it ?

    <
    authentication mode="Forms">
        <
    forms name=".ASPNET" loginUrl="~/sitefinity/login.aspx" protection="All" timeout="30" path="/"/>
    </
    authentication>



    thanks 

  2. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    25 Nov 2011
    Link to this post
    Hi Wei,

    You can change the session timeout settings by navigating to Administration -> Settings -> Advanced -> Security and change the value of the following fields:

    AuthCookieTimeoutDescription
    BackendUsersSessionTimeoutDescription


    to whatever you want.

    Kind regards,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
  3. Wei
    Wei avatar
    6 posts
    Registered:
    23 Nov 2011
    28 Nov 2011
    Link to this post
    it worked . thanks very much!
  4. Rijo
    Rijo avatar
    1 posts
    Registered:
    14 Feb 2012
    17 Jul 2014
    Link to this post

    dd

  5. Nagy
    Nagy avatar
    2 posts
    Registered:
    08 Jun 2015
    08 Jun 2015
    Link to this post

    Hi,

    If I set this BackendUsersSessionTimeout under in "Sitefinity Administration -> Settings -> Advanced -> Security" menu it works well in my application.

    How can I get the value of this session timeout value to write into my application screen?

    I have try to write the "Session.Timeout" variable but I get constantly 20 minutes even if I set "BackendUsersSessionTimeout" to 1 minutes.

  6. Svetoslav Manchev
    Svetoslav Manchev avatar
    735 posts
    Registered:
    29 Nov 2016
    10 Jun 2015
    Link to this post
    Hi Nagy,

    This setting is available and could be get from the SecurityConfig file. To do you can use the following code snippet:
    using Telerik.Sitefinity.Configuration;
    using Telerik.Sitefinity.Security.Configuration;
    ...
    var conf = Config.Get<SecurityConfig>();
    var sessionTimeout = conf.BackendUsersSessionTimeout;

    Regards,
    Svetoslav Manchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  7. Nagy
    Nagy avatar
    2 posts
    Registered:
    08 Jun 2015
    10 Jun 2015 in reply to Svetoslav Manchev
    Link to this post

    Hi,

    Your example is very useful and works well!

    Thank you so much!

     

     

     

7 posts, 1 answered