+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / SitefinityInternalEndpoint no longer works after multisite implemented on Azure

SitefinityInternalEndpoint no longer works after multisite implemented on Azure

4 posts, 0 answered
  1. Colleen
    Colleen avatar
    2 posts
    Registered:
    28 Jun 2012
    28 Oct 2014
    Link to this post

    We have our Sitefinity 6.3 website hosted on Azure with five instances. Before we added the multisite module, the internal endpoint SitefinityInternalEndpoint made sure that all instances were in sync. Now we have implemented the multisite module and have multiple bindings with distinct host headers to accommodate an additional website we created in the Sitefinity backend. The host headers seem to be working just fine, but the internal endpoint no longer works.

    This snippet from the ServiceDefinition in our Azure deployment project (with names changed to protect the innocent) shows the setup. Any ideas?

    (The staging host header allows me to bypass the fact that Azure prevents me from browsing to the staging instance of the site after multiple host headers are added - I just add the current dynamic IP to my local hosts file.)

    <WebRole name="Cms" vmsize="Medium">
        <Sites>
          <Site name="Web">
            <Bindings>
              <Binding name="Endpoint1" endpointName="Endpoint1" hostHeader="www.sitename.org" />
              <Binding name="Endpoint2" endpointName="Endpoint1" hostHeader="subdomain.sitename.org"/>
              <Binding name="Endpoint3" endpointName="SitefinityInternalEndpoint" />
              <Binding name="Endpoint4" endpointName="HttpsIn" hostHeader="www.sitename.org"/>
              <Binding name="Endpoint5" endpointName="Endpoint1" hostHeader="staging.sitename.org" />
              <Binding name="Endpoint6" endpointName="Endpoint1" hostHeader="sitename.org" />
             </Bindings>
          </Site>
        </Sites>
        <Endpoints>
          <InputEndpoint name="Endpoint1" protocol="http" port="80" />
          <InputEndpoint name="HttpsIn" protocol="https" port="443" certificate="certificatename" />
          <InternalEndpoint name="SitefinityInternalEndpoint" protocol="http" />
        </Endpoints>

  2. Svetoslav Manchev
    Svetoslav Manchev avatar
    735 posts
    Registered:
    06 Dec 2016
    31 Oct 2014
    Link to this post
    Hello Colleen,

    The setting you mentioned should not be related to Sitefinity site only. So you can try to set multipleSiteBindingsEnabled to true as proposed in that blog post point 3
    <system.serviceModel>
      <serviceHostingEnvironment multipleSiteBindingsEnabled=”true” >
      </serviceHostingEnvironment>
    </system.serviceModel>

    I hope this helps.

    Regards,
    Svetoslav Manchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  3. Colleen
    Colleen avatar
    2 posts
    Registered:
    28 Jun 2012
    03 Nov 2014 in reply to Svetoslav Manchev
    Link to this post
    Thanks, Svetoslav. We already have this setting like you suggested. Something seems to be preventing SitefinityInternalEndpoint from working.
  4. Svetoslav Manchev
    Svetoslav Manchev avatar
    735 posts
    Registered:
    06 Dec 2016
    05 Nov 2014
    Link to this post
    Hi Colleen,

    I have answer you in the opened support ticket.

    Once you have the solution, you can share it with the community.

    Regards,
    Svetoslav Manchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
4 posts, 0 answered