+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Sitemap Generator using the wrong host name

Sitemap Generator using the wrong host name

3 posts, 0 answered
  1. Darrin Robertson
    Darrin Robertson avatar
    105 posts
    Registered:
    18 Jul 2004
    25 Nov 2014
    Link to this post

    Hi

    My site map generator is setting the host name as my staging name. ie

    http://stagingsite.net/about some are even http://localhost/blog/....

    Now I am running the live site the genertated host names are not changing. They are still using the old staging names. I have reset and re run the site generation but even new pages added to the site get the staging domain name.

    How do I instruct the Sitefinity sitemap generator to use my live domain url rather than carry on generting the name from the old staging domain name?

     

  2. Atanas Valchev
    Atanas Valchev avatar
    414 posts
    Registered:
    04 Jan 2016
    28 Nov 2014
    Link to this post
    Hi,

    You can configure the host in the advanced settings: Administration - Settings - Advanced - System - Site URL Settings. After you enter the host and save, you need to restart for the configuration to take effect.

    Regards,
    Atanas Valchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  3. Darrin Robertson
    Darrin Robertson avatar
    105 posts
    Registered:
    18 Jul 2004
    30 Nov 2014 in reply to Atanas Valchev
    Link to this post

    I did manage to correct this issue.

    I initially followed advice of Atanas but this threw a URI error when generating the Sitemap. But switching back then had most of the Sitemap start generating the correct host names.

    All expect the blog posts. They still had 'localhost' as the host name. Eventually I got this corrected by renaming my page. (It was a page error not a blog error)

    I can not say why this happened in the first place but these steps got it all sorted out.

     

3 posts, 0 answered