1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / SMTP Setting

SMTP Setting

6 posts, 0 answered
  1. siby
    siby avatar
    48 posts
    Registered:
    21 Feb 2009
    26 Aug 2010
    Link to this post

    Hi,

    If no authentication is required for smtp , how to set up the seetings so that news letter can be send.

    The following message am getting.

    No mail server has been set

    though have configured like below

    <system.net>
        <mailSettings>
          <smtp >
            <network host="localhost" defaultCredentials="true" port="25" />
          </smtp>
        </mailSettings>
      </system.net>

    Regards,

    Siby Chacko

  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    26 Aug 2010
    Link to this post
    Hi siby,

    There would not be a problem to use a host without credentials. Use SystemConfig.config ~/SitefinityWebApp/App_Data/Sitefinity/Configuration/SystemConfig.config

    <?xml version="1.0" encoding="utf-8"?>
    <systemConfig>
        ....
                  ......
        </applicationModules>
        <smtpSettings host="hostname" domain="domainname" />
        <licensing />
        <uiTimeZoneSettings />
    </systemConfig>


    or backend UI - Settings >> Configuration >> System

    We use SmtpClient.Credentials Property  to get/set credentials to use for authentication

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. siby
    siby avatar
    48 posts
    Registered:
    21 Feb 2009
    26 Aug 2010
    Link to this post
    Hi

    I could not find any path "~/SitefinityWebApp/App_Data/Sitefinity/Configuration/SystemConfig.config".
    Also any Admin site module for "backend UI - Settings >> Configuration >> System"
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    26 Aug 2010
    Link to this post
    Hello siby,

    Check attached screentshot. SystemConfig.config should be in the specified location, otherwise you will not be able to use the CMS.

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. siby
    siby avatar
    48 posts
    Registered:
    21 Feb 2009
    26 Aug 2010
    Link to this post
    Hi but am using sitefinity 3.7, there the UI is quite different once logged in to the cms. I cannot see
    system menu. Instead can see tyhe menus "dahboard", "pages","modules", "files" and "administration" and "livesite".

  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    26 Aug 2010
    Link to this post
    Hi siby,

    The request you have opened is for Sitefintiy 4.0. In 3.x it is not possible use set up Newsletters module without username and password. If you are trying to send the email through your own control, please check the SMTP server settings.

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
6 posts, 0 answered