1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Social sharing

Social sharing

8 posts, 1 answered
  1. Eric
    Eric avatar
    60 posts
    Registered:
    24 Feb 2011
    22 Dec 2011
    Link to this post
    Hi,
    Maybe I'm feeling extra dumb or blind today, but I can't for the life of me figure out how to add the new social sharing icons to be able to share pages and content and things. I've upgraded to 4.4. I only have Facebook Like/Feed and Twitter Feed in my widgets. I can see where to choose them under Settings, but not where to actually do something with them. Can someone please point me in the right direction? Thanks!

    Eric
  2. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    22 Dec 2011
    Link to this post
    Seems that it ties into the "content" widgets, it's not a widget itself

    So like plop in a new Content widget, you should see the checkbox.
    Or edit the properties of an event widget and you'll see it under the single and list tabs
    Answered
  3. Eric
    Eric avatar
    60 posts
    Registered:
    24 Feb 2011
    22 Dec 2011
    Link to this post
    Ok, thanks! :) I see them now, but are they only on pages? They can't seem to be used in a Template, yah?

    Also, I'm logged in with my facebook acct, but its giving me an error message saying I wasn't able to post to my wall. Am I missing something?
  4. Daniel Plomp
    Daniel Plomp avatar
    952 posts
    Registered:
    18 Feb 2004
    22 Dec 2011
    Link to this post
    Just create a new UserControl, add in the <telerik:RadSocialShare /> and configure it to your needs :)

    Regards,
    Daniel
  5. Eric
    Eric avatar
    60 posts
    Registered:
    24 Feb 2011
    22 Dec 2011
    Link to this post
    Ok, thanks! I'll see if I can't figure that out. Also, I think facebook is failing because I'm on my local box, I have a feeling it will work better when I get the site up to production. Thanks!

    Eric
  6. Daniel Plomp
    Daniel Plomp avatar
    952 posts
    Registered:
    18 Feb 2004
    22 Dec 2011
    Link to this post
    Yup, that's true. Don't forget to setup your namespaces in either your template, or page:


    Regards,
    Daniel
  7. Eric
    Eric avatar
    60 posts
    Registered:
    24 Feb 2011
    22 Dec 2011
    Link to this post
    Where/how do I do that?
  8. Tim
    Tim avatar
    258 posts
    Registered:
    22 Jun 2011
    25 Dec 2011
    Link to this post
    Eric,

    You can add it to your <html> tag like so:


8 posts, 1 answered