+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Sporadic NullReferenceException exception in RadAsyncUpload

Sporadic NullReferenceException exception in RadAsyncUpload

3 posts, 0 answered
  1. Radoslav
    Radoslav avatar
    3 posts
    Registered:
    29 Oct 2013
    21 Nov 2013
    Link to this post
    Hey everyone,

    I've installed my custom module with page and everything.
    I have RadAsyncUpload control on the page.
    Everything seems to work normally but sometimes when I try to open the page on the module I get this exception message:

    Object reference not set to an instance of an object.
    [NullReferenceException: Object reference not set to an instance of an object.]
       Telerik.Sitefinity.Web.UI.Backend.MainMenu.CreateRadMenuItemFromNode(SiteMapNode node) +2260
       Telerik.Sitefinity.Web.UI.Backend.MainMenu.OnLoad(EventArgs e) +849
       System.Web.UI.Control.LoadRecursive() +70
       System.Web.UI.Control.LoadRecursive() +189
       System.Web.UI.Control.LoadRecursive() +189
       System.Web.UI.Control.AddedControl(Control control, Int32 index) +256
       Telerik.Sitefinity.Web.UI.SimpleView.CreateChildControls() +238
       System.Web.UI.Control.EnsureChildControls() +188
       System.Web.UI.Control.PreRenderRecursiveInternal() +59
       System.Web.UI.Control.PreRenderRecursiveInternal() +221
       System.Web.UI.Control.PreRenderRecursiveInternal() +221
       System.Web.UI.Control.PreRenderRecursiveInternal() +221
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +4296


    The exception seems to be thrown by the RadAsyncUpload control and I'm trying to find out what's the problem here.

    Rebuilding the project solve the problem temporary though.

    I'm looking for permanent solution for my issue.

    Any help will be greatly appreciated.

    Thanks in advance!

    Radoslav,
    eVeliko Team
  2. Elena Ganeva
    Elena Ganeva avatar
    36 posts
    Registered:
    20 Jul 2016
    21 Nov 2013
    Link to this post

    Hello Radoslav,

    I have been looking into the stack trace that you sent and I notice that the exception occurs while initializing the backend MainMenu. From this I could conclude that there may be an issue with the way that you initialize the custom module. Could you make sure that you are following the instruction for installing your module:

    http://www.sitefinity.com/documentation/documentationarticles/developers-guide/sitefinity-essentials/modules/creating-custom-modules/module-installation-fluent-api

    If this doesn’t resolve your issue is it possible to share the code from your custom module so we can try to reproduce the mentioned issue.

    Regards,
    Elena Ganeva
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Radoslav
    Radoslav avatar
    3 posts
    Registered:
    29 Oct 2013
    26 Nov 2013 in reply to Elena Ganeva
    Link to this post
    Hello Elena,

    Thanks for the reply. I checked out the link you sent me and there are small differences with mine initialization. I will change it the way it's shown in the link and see if I will get any better. If I still get the same exception I will make a post again and might share the code with you so you can try to help me. Thanks again!

    Best regards,

    Radoslav,
    eVeliko Team
3 posts, 0 answered