+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Streaming videos on IOS devices

Streaming videos on IOS devices

23 posts, 0 answered
  1. AmrElsayed
    AmrElsayed avatar
    87 posts
    Registered:
    18 Jul 2012
    23 Nov 2011
    Link to this post
    Hello,

    We are using the Videos content module of sitefinity in our 4.2 website, and flowplayer to display the videos on the front end pages, however, streaming the videos on IOs  devices (IPad, IPhone.. ) is not working properly, even if we paste the url of the video directly to the mobile browser, we get "Cannot Play Movie, The server is not correctly configured".

    Why is this happending and is there any workaround for this issue? We face this issue in case of using both the Database and File System providers. We need to use the built-in module since it offers more meta data including the title, description, classifications,... and we don't want to store these files on the file system of the server as they will lose all their categorization features.

    Thanks
  2. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    23 Nov 2011
    Link to this post
    Flowplayer is flash, are you using the iOS\iPad plugin for it so it will use the HTML5 player instead?
  3. AmrElsayed
    AmrElsayed avatar
    87 posts
    Registered:
    18 Jul 2012
    23 Nov 2011
    Link to this post
    Hi Steve,

    FlowPlayer has a fallback behavior to html5 and it is working perfectly as long as the mp4 is stored locally not through the videos module. We are having problems streaming an mp4 out of the videos module directly through the ios browser, we get "Cannot Play Movie, The server is not correctly configured".

    So basiclly streaming videos directly works but not videos from the videos module regardless of the storage model (file or database).

    Amr
  4. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    24 Nov 2011
    Link to this post
    Hi Amrelsayed,

    I did some research and found out that this is rather an Apple issue. Here are some useful articles and forum threads that I found:

    http://forums.macrumors.com/showthread.php?t=724397

    https://discussions.apple.com/thread/2141381?threadID=2141381&tstart=0

    I don't this is a Sitefinity issue. I also found this article - it looks like the video itself must be in a specific format so the iPhone/iPad plays it

    http://www.metaltoad.com/blog/iphone-video-streaming-drupals-file-system

    Best wishes,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. AmrElsayed
    AmrElsayed avatar
    87 posts
    Registered:
    18 Jul 2012
    24 Nov 2011
    Link to this post
    Hi Lubomir,

    Thanks for the response though there seems to be some confusion over the source of the issue.

    What we are saying is simply that video files that work 'perfectly' on apple devices 'stop' working when they hosted within the sitefinity videos module.

    Actually the third link you mentioned from Metaltoad probably explains the issue within Sitefinity which is the lack of support for 'byte range requests', the link you mentioned suggests by-passing the transfer to Apache via the use of X-Sendfile module or in Windows terms would be to by-pass the file transfer to IIS. The questions is how do we do the same for Sitefinity?

    To summarize the issue: mp4 Apple compliant files work when requested directly out of IIS but don't work when requested out of Sitefinity Videos Module.

    What we need is a workaroud, httphandler, configuration tweek or code update to work around this problem.

    Amr
  6. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    29 Nov 2011
    Link to this post
    Hello Amrelsayed,

    I did some research and I found the following projects that implement X-Sendfile functionality for IIS:

    https://github.com/stakach/IIS-X-Sendfile-plugin

    http://www.helicontech.com/ape/

    I hope they will be useful for you.

    All the best,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. AmrElsayed
    AmrElsayed avatar
    87 posts
    Registered:
    18 Jul 2012
    30 Nov 2011
    Link to this post
    Hi Lubomir,

    I appreciate the continued support, have you confirmed or consider this thread a Sitefinity bug where we can expect a proper built-in resolution in a future service pack?

    Amr
  8. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    02 Dec 2011
    Link to this post
    Hi Amrelsayed,

    I have logged a new PITS feature request for this - here is the public URL

    http://www.telerik.com/support/pits.aspx#/public/sitefinity/8712

    You can vote for it and if it gets enough votes it will be implemented.

    Greetings,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  9. Robert McCarter
    Robert McCarter avatar
    5 posts
    Registered:
    13 May 2010
    12 Dec 2011
    Link to this post
    Clicking on the link to the PITS issue does NOT take me to the issue (to vote for it or check-up on it).
    Instead, it takes me to the main PITS page.  How can we get to this issue?
    I tried searching for the ID but that didn't work either.
  10. Robert McCarter
    Robert McCarter avatar
    5 posts
    Registered:
    13 May 2010
    12 Dec 2011
    Link to this post
    Clicking on the link to the PITS issue does NOT take me to the issue (to vote for it or check-up on it).
    Instead, it takes me to the main PITS page.  How can we get to this issue?
    I tried searching for the ID but that didn't work either.
    (Even just posting this reply resulted in an error, although I see that the post was accepted!)
  11. Brandon
    Brandon avatar
    50 posts
    Registered:
    30 Jul 2009
    12 Dec 2011
    Link to this post
    i posted about this exact issue back in april 2011. i cannot believe this has not been resolved already.

    here's a post to my original thread on the issue. of course this was with version 3.x but we moved back to 4.1 shortly after all of these. neither worked.

    http://www.sitefinity.com/devnet/forums/sitefinity-3-x/general-discussions/mp4-uploaded-to-image-document-library.aspx
  12. Brandon
    Brandon avatar
    50 posts
    Registered:
    30 Jul 2009
    12 Dec 2011
    Link to this post
    i posted about this exact issue back in april 2011. i cannot believe this has not been resolved already.

    here's a post to my original thread on the issue. of course this was with version 3.x but we moved back to 4.1 shortly after all of these. neither worked.

    http://www.sitefinity.com/devnet/forums/sitefinity-3-x/general-discussions/mp4-uploaded-to-image-document-library.aspx
  13. Richard Baugh
    Richard Baugh avatar
    201 posts
    Registered:
    22 Aug 2012
    17 Sep 2012
    Link to this post
    I know this is an old thread, but I too was at a point where this was an issue for one of our projects. I contacted Sitefinity about this to see if there was any new information but there really wasn't. Looking around the web I found a couple of solutions that seemed to work but the issue was getting the code implemented into the Sitefinity handler for the video library. With the help from Sitefinity support, I was able to implement some code into the library handler and was successful in getting videos from Sitefinity to play on mobile devices.

    The first thing to note is that this is only successful when using the file system as the library storage provider. When using the database as the storage provider, Sitefinity stores the video in blocks, which are separate db records, and it becomes a slight issue when trying to use the range request.

    You can find the code here. There are two files to work with. The first is the HttpHandler and it needs to implement the Sitefinity LibraryHttpHandler. This handler will override a method that occurs after the file has been run through the permissions. So when this handler kicks in, the file is known to be available to the user requesting the video. The second file is the global.asax code that is needed to insert this HttpHandler in for the Sitefinity LibraryHttpHandler.

    For more information on the base range request handler that was used, you can have a look at the original post: Range-Specific Requests in ASP.NET
  14. Richard Baugh
    Richard Baugh avatar
    201 posts
    Registered:
    22 Aug 2012
    17 Sep 2012
    Link to this post
    Sorry for the double post, the first time it said it threw an error.
  15. Jeffrey Monroe
    Jeffrey Monroe avatar
    7 posts
    Registered:
    06 Feb 2005
    08 Jan 2013 in reply to Richard Baugh
    Link to this post
    Hi Richard,

    The link for the code is broken. Is there another link to your sample code. Also, have you received any information from Telerik whether they have fixed this problem in the Video library service?

    Thanks,
    -jm
  16. Jen Peleva
    Jen Peleva avatar
    568 posts
    Registered:
    10 Nov 2016
    10 Jan 2013
    Link to this post
    Hello guys,

    I believe this is the correct link to the post Brandon was talking about:

    http://www.sitefinity.com/developer-network/forums/general-discussions/mp4-uploaded-to-image-document-library 

    The PITS feature request has not been implemented yet. We're doing our best to keep Sitefinity up-to-date with your requirements and we're implementing the features, depending of the number of votes they collect. 

    All the best,
    Jen Peleva
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  17. Richard Baugh
    Richard Baugh avatar
    201 posts
    Registered:
    22 Aug 2012
    11 Jan 2013 in reply to Jeffrey Monroe
    Link to this post
    Jeffery,
        I guess I was doing some winter cleaning and removed the file from the directory. I have added it back in. The link to my code should be operational. I haven't looked at the link Jen provided, but this is my original working code. You just have to make sure your library is setup to save to the file system.
  18. Michael
    Michael avatar
    67 posts
    Registered:
    16 Mar 2012
    04 Mar 2013 in reply to Richard Baugh
    Link to this post

    Just a note: This completely breaks Safari 6 on the desktop as well as breaking Safari on iOS, as Apple has made byte range requests mandatory for loads there as well (Likely due to QuickTime now requiring them, and it handling video loads).

    Richard's little fix actually works... which means it shouldn't be too hard for Telerik to pull in those changes.

    I'd say at this point, this issue really needs attention.

  19. codicezerouno
    codicezerouno avatar
    21 posts
    Registered:
    02 Feb 2009
    04 Oct 2013
    Link to this post
    Hi guys,
    i am encountering same issue: mp4 video served by Sitefinity won't play on IOS devices; on desktop browser it works.

    I figure out that the problem is the lack of support for 'byte range requests' as some of you explained too.

    Is there any news? Any solution?

    Greatings,
    Stefano
    Codicezerouno
  20. Michael
    Michael avatar
    67 posts
    Registered:
    16 Mar 2012
    07 Oct 2013 in reply to codicezerouno
    Link to this post
    See Richard's post above. His modified LibraryHttpHandler is the best we have right now. And vote for the PITS issue.
  21. Jeffrey Monroe
    Jeffrey Monroe avatar
    7 posts
    Registered:
    06 Feb 2005
    09 Oct 2013
    Link to this post
    I have a solution for this which uses a modified version of Richard's Library Handler. Anyone interested can send me an email to Jeffrey@mobmedia.com with the version you are looking for and I will send you the assemblies.

    Cheers,
    -jm
  22. Nicholas
    Nicholas avatar
    9 posts
    Registered:
    30 Jun 2013
    08 Aug 2014
    Link to this post

    The proper PITS link is here

  23. Vassil Vassilev
     Vassil Vassilev avatar
    308 posts
    Registered:
    21 Jan 2015
    13 Aug 2014
    Link to this post
    Hello,

    All feature requests / bug reports are moved in our Feedback Portal.

    Regards,
    Vassil Vassilev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
23 posts, 0 answered