1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / stuck on widget creation

stuck on widget creation

13 posts, 0 answered
  1. CMSGuru
    CMSGuru avatar
    42 posts
    Registered:
    15 Feb 2011
    28 Jul 2011
    Link to this post
    I'm trying to create a new widget that when the user clicks the edit button they can enter in a title, an URL and select an image. however, I can't get it to work, the only thing I can get to work on my widget is an htmlfield and I don't want that, I want user to see the following when they click edit

    Title: <textbox>
    URL: <textbox>
    Image: image uploader/selector

    click save and then see what they just entered in on the page. So far I can only get an htmlfield to work, how can I get the above items to work? I looked at the doc and so far no luck
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    01 Aug 2011
    Link to this post
    Hello Newtocms,

    Please review the attached sample control with control designer. It uses the images selector from the forum post, but instead of opening it in a new RadWindow it opens it in the context of the designer, which is a little bit simpler approach.

    Greetings,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. CMSGuru
    CMSGuru avatar
    42 posts
    Registered:
    15 Feb 2011
    01 Aug 2011
    Link to this post
    Thanks Rad, I'll give it a shot and post back with the results (worked for failed)  :)
  4. CMSGuru
    CMSGuru avatar
    42 posts
    Registered:
    15 Feb 2011
    01 Aug 2011
    Link to this post
    when I drag my widget to the page and click on the {edit} button, all I'm getting is the default edit screen, I'm not getting the page to allow me to enter title, and upload/select and image. what am I missing?
  5. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    01 Aug 2011
    Link to this post
    Check if there are any JS errors. It seems that the script component of the designer is not loading properly for some reason.

    Greetings,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. CMSGuru
    CMSGuru avatar
    42 posts
    Registered:
    15 Feb 2011
    01 Aug 2011
    Link to this post
    No JS errors, no errors in general, its just not loading
  7. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    01 Aug 2011
    Link to this post
    Hello Newtocms,

    Could you try adding MediaContentSelectorView inside the designer template as shown here and see if there will be a result. If not then you have not registered the control correctly or class library properly to the solution


    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  8. CMSGuru
    CMSGuru avatar
    42 posts
    Registered:
    15 Feb 2011
    01 Aug 2011
    Link to this post
    same results, I see the default edit screen. I'm able to add the MediaContentViewer to my designer page, but I don't see it when I click edit.

    What I did is this:
    in my project I created a folder named Controls under that folder I created another one named ImageSelector and then I placed all of the files under the ImageSelector folder, I then changed all of the namespace references to point to SitefinityWebApp.Controls.ImageSelector as well as change the reference to the templates, js file, etc.

  9. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    01 Aug 2011
    Link to this post
    Hello Newtocms,

    All templates, js, css should be build as embedded resources. In your control you should have a reference to the control designer using ControlDesigner attribute. Inside the ControlDesigner you need to have a reference to the embedded template of the designer where you need to declare your controls.

    You can check the SDK where you will see how this is done.

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  10. CMSGuru
    CMSGuru avatar
    42 posts
    Registered:
    15 Feb 2011
    01 Aug 2011
    Link to this post
    I have the js set to 'embedded resources'
  11. CMSGuru
    CMSGuru avatar
    42 posts
    Registered:
    15 Feb 2011
    01 Aug 2011
    Link to this post
    I have tried everything and still no luck. If I strip out everything and put in an htmlfield, then I can see that, anything else, nothing.

    what am I missing? I have the .ascx files as embedded resources, the js as an embedded resources and still nothing, when I click [edit] on my widget I'm getting the default screen
  12. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    02 Aug 2011
    Link to this post
    Hello Newtocms,

    Please open a support request and attach the code that you have - the class library that you use.

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  13. CMSGuru
    CMSGuru avatar
    42 posts
    Registered:
    15 Feb 2011
    02 Aug 2011
    Link to this post
    open a support ticket with community edition I'm using?
13 posts, 0 answered