1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Switch User Error

Switch User Error

5 posts, 0 answered
  1. Andrei
    Andrei avatar
    553 posts
    Registered:
    27 Nov 2008
    04 Mar 2011
    Link to this post
    Hi, I get this when trying to switch users. I am using two applications at one so switching between them.

    Server Error in '/' Application.

    You are trying to access item that no longer exists. The most probable reason is that it has been deleted by another user.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: Telerik.Sitefinity.SitefinityExceptions.ItemNotFoundException: You are trying to access item that no longer exists. The most probable reason is that it has been deleted by another user.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [ItemNotFoundException: You are trying to access item that no longer exists. The most probable reason is that it has been deleted by another user.]
       DynamicModule.ns.Wrapped_OpenAccessMembershipProvider_ea248b56cfd248bf99ca22416803b1f6.GetUser(Guid id) +298
       Telerik.Sitefinity.Security.UserManager.GetUser(Guid id) +73
       Telerik.Sitefinity.Security.SecurityManager.LogoutImpl(String providerName, Guid userId, String userName, Credentials credentials) +277
       Telerik.Sitefinity.Security.SecurityManager.Logout(String providerName, Guid userId) +178
       Telerik.Sitefinity.Security.SecurityManager.Logout() +257
       Telerik.Sitefinity.Security.Web.UI.LogoutForm.DoLogout(String navigateUrl) +32
       Telerik.Sitefinity.Security.Web.UI.LogoutForm.LogoutButton_Command(Object sender, CommandEventArgs e) +47
       System.Web.UI.WebControls.LinkButton.OnCommand(CommandEventArgs e) +115
       System.Web.UI.WebControls.LinkButton.RaisePostBackEvent(String eventArgument) +169
       System.Web.UI.WebControls.LinkButton.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) +9
       System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +13
       System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) +176
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +5563
    


    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1 
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    04 Mar 2011
    Link to this post
    Hi Andrei,

    Do you have two membership providers? How have you configured the two applications in one?
    The error say that the user you used does not exist the the OA provider after you try to log out.

    Best wishes,
    Ivan Dimitrov
    the Telerik team
  3. Andrei
    Andrei avatar
    553 posts
    Registered:
    27 Nov 2008
    04 Mar 2011
    Link to this post
    No Ivan, the applications are not in one. They are on the same development PC. It does not matter though, as I wiped out all the cookies and then it works OK.

    I am desperately awaiting something on this pos: http://www.sitefinity.com/devnet/forums/sitefinity-4-x/general-discussions/newsletter-enhancements-in-q1-2011.aspx

    I am very worried about it. I have restored the database to an earlier point and still shows the error. I am trying to create a new application and link it to the existing database, but it says that there is an administrator already and does not allow me to do anything. 

    What a nightmare i am going through with Sitefinity at the moment.

    Hope you can help me rather quickly,
    Andrei
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    08 Mar 2011
    Link to this post
    Hi Andrei,

    We sent a reply to the forum post and your support request.

    Regards,
    Ivan Dimitrov
    the Telerik team
  5. Andrei
    Andrei avatar
    553 posts
    Registered:
    27 Nov 2008
    08 Mar 2011
    Link to this post
    Ivan,

    Thanks. The issue is sorted, however, a new one followed so I started all over again.
    For now, things seem to be stable.

    Many thanks for your help,
    Andrei
5 posts, 0 answered