1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Telerik.Sitefinity.Licensing.NotRegisteredModule

Telerik.Sitefinity.Licensing.NotRegisteredModule

6 posts, 0 answered
  1. mbd
    mbd avatar
    3 posts
    Registered:
    05 Jul 2007
    28 Apr 2011
    Link to this post
    Sitefinity 4.1.1339 Community Edition

    I've added a user with Author, Designer, and Editor roles. When this user tries to log in, an error is thrown "Exception of type 'Telerik.Sitefinity.Licensing.NotRegisteredModule' was thrown." When I change the role for this user to include Administrator, the user can log in just fine.

    Any ideas?

    Thanks,
    Michael
  2. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    18 Aug 2017
    28 Apr 2011
    Link to this post
    Hi mbd,

    Make sure you log off with all other users you are using and then attempt to log in because Sitefinity Community edition can support only 1 concurrent backend user at a time.

    Please don`t hesitate to write back if the problem persists.

    Regards,
    Stanislav Velikov
    the Telerik team

  3. mbd
    mbd avatar
    3 posts
    Registered:
    05 Jul 2007
    28 Apr 2011
    Link to this post
    I'm pretty certain no other user is logged on. I'm doing all this on my development machine so I'm the only one testing. And actually, I think the user does get logged on, at least in the eyes of Sitefinity. The reason I say this is that if I close the browser and go back to try to log in the same user I get a Sitefinity message that reads:

    "Someone is already using this username and password from another computer or browser. To proceed, you need to log him/her off."

    When I click the "Log the other user off and enter" button and agree to the next dialog warning, the same error is thrown.

    Michael
  4. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    18 Aug 2017
    29 Apr 2011
    Link to this post
    Hello mbd,

    Please accept our apologies for the inconvenience caused. this appears to be a bug on Sitefinity Community edition and it is logged in PITS where you can track its progress until resolved.
    For a workaround set all users the administrator role and you will avoid this error. You can edit the permissions for the administrator`s role from Administration --> Permissions.
    If you need further assistance don`t hesitate to write back.


    Best wishes,
    Stanislav Velikov
    the Telerik team

  5. mbd
    mbd avatar
    3 posts
    Registered:
    05 Jul 2007
    29 Apr 2011
    Link to this post
    Thanks for the reply.

    Fortunately, I can get by with setting this user as an Administrator. I plan to add another user who I do not want to have the Admin role but I can wait to add that person until this gets resolved.

    On a similar note, not sure if this is related but I added both the Login Name and the Log In Status widgets to my template. When I log on to the live site (not the back end), my name is displayed as expected. But, when the other user logs on, their name is not displayed. My name is the first name entered when the DB was created. 

    Thanks,
    Michael
  6. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    18 Aug 2017
    29 Apr 2011
    Link to this post
    Hi mbd,

    Unfortunately  the issues you are experiencing with Login Name and Login Status widgets are bugs connected with user permissions. You can track the bug fix progress in PITS.

    I appreciate your understanding on the previous issue with user roles and hope this will not make negative impact on your work.
    Feel free to contact me at any time if you encounter other problems.

    Kind regards,
    Stanislav Velikov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
6 posts, 0 answered