1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / The resource cannot be found

The resource cannot be found

4 posts, 0 answered
  1. H.J.E. Coppen
    H.J.E. Coppen avatar
    13 posts
    Registered:
    25 Nov 2008
    30 Sep 2010
    Link to this post
    I installed Sitefinity Beta 2 and upgraded my project. When i open the admin "Profile" i get this error:

    The resource cannot be found.

    Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.

    Requested URL: /Sitefinity/Profile

    This problem does not occur with newly created projects. I have also had this problem earlier with Beta 1 when editing users or changing permissions. Strangely this was solved after editing and saving my homepage (?).
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    01 Oct 2010
    Link to this post
    Hi  Coppen,

    Could you check the fire bug console and what is returned by /Sitefinity/Services/Security/Users.svc. It is possible that the ID of the user is somehow not correct and the web service fails to retrieve your data. Before we call the web service there is a GET request to "profile" page. If you reset the database does the issue still occurs?

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. H.J.E. Coppen
    H.J.E. Coppen avatar
    13 posts
    Registered:
    25 Nov 2008
    06 Oct 2010
    Link to this post
    I don't know where to look in the Firebug console. The page source returns "File not found exception", but what do you mean exactly?
    When I browse to /Sitefinity/Services/Security/Users.svc, a JSON file is downloaded containing correct users information.
    And how can I reset my database? As I have mentioned before, newly created projects don't have this problem.
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    06 Oct 2010
    Link to this post
    Hello Hugo,

    We cannot reproduce this issue locally when you upgrade from BETA1 to BETA2 and it looks like that you have made some changes before you get this error. You can use the newly created projects where the issue does not persist and send us the problematic project and its database.

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
4 posts, 0 answered