+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Type is not resolved for member 'Microsoft.IdentityModel.Claims.ClaimsPrincipal.Microsoft.IdentityModel

Type is not resolved for member 'Microsoft.IdentityModel.Claims.ClaimsPrincipal.Microsoft.IdentityModel

1 posts, 0 answered
  1. Jared
    Jared avatar
    122 posts
    Registered:
    04 Apr 2013
    14 Mar 2014
    Link to this post

    We are getting the following error on our server(s) that use IIS8.:

    Message: Type is not resolved for member 'Microsoft.IdentityModel.Claims.ClaimsPrincipal.Microsoft.IdentityModel

    I have came across a fix for this in the following KB article:

    http://www.sitefinity.com/developer-network/knowledge-base/getting-type-is-not-resolved-for-member-microsoft-identitymodel-claims-claimsprincipal-exception

     One thing I have noticed is that the Windows Feature, Windows Identity Foundation, is not enabled on our server.  I know we can just add the DLL (which is in our bin folder of our solution files) like the link above states, but was wondering if by activating the feature I mentioned solve the issue?  If that is the case, should that be mentioned somewhere in the install steps?  When the error randomly occurs, the users are not getting a error, but we think that is because we have load balancing set up.  We noticed that when the error occurs, it restarts the App Pool automatically.  It is believed that when that happens the users get bounced to the "other" server, so in return do not see any errors come on the screen to them.

    We do have all the steps correct in the following link:

    http://www.sitefinity.com/documentation/documentationarticles/switching-to-claims-based-authentication

     Has anyone experienced this error and able to shed some more light on the situation at hand?  Thanks!

1 posts, 0 answered