+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / upgrade site from 4.0 to 6.0

upgrade site from 4.0 to 6.0

18 posts, 0 answered
  1. Ajay
    Ajay avatar
    19 posts
    Registered:
    24 Aug 2012
    23 May 2013
    Link to this post
    hi,
     
    i want to upgrade site from 4.0 to 6.0 .
    i follow 4.0 » 4.2 » 4.4 » 5.0 » 5.2 » 5.4 » 6.0 step


    please tell me  how to download  sitefinity version 4.2 ,sitefinity version 4.4 
    so on ..



  2. Arno
    Arno avatar
    249 posts
    Registered:
    08 Sep 2010
    23 May 2013 in reply to Ajay
    Link to this post
    Hi,

    Just go here.
  3. Ajay
    Ajay avatar
    19 posts
    Registered:
    24 Aug 2012
    24 May 2013 in reply to Arno
    Link to this post
    hi

    i upgrade site from 4.2 to 4.4

    i got error 

    Could not load file or assembly 'Telerik.Sitefinity, Version=4.2.1733.0, Culture=neutral, PublicKeyToken=b28c218413bdf563' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

    tell me how to fixed
  4. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    24 May 2013 in reply to Ajay
    Link to this post
    Dear Ajay

    a) did you follow the instructions to the dot
    b) did you bild your solution
    c) did you use build or rebuild   
    d) any custom module which is referencing the old 4.2 version

    Markus
  5. Ajay
    Ajay avatar
    19 posts
    Registered:
    24 Aug 2012
    24 May 2013 in reply to Markus
    Link to this post
    Dear Markus
     
    i follow all step but it still giving same error 

    Could not load file or assembly 'Telerik.Sitefinity, Version=4.2.1733.0, Culture=neutral, PublicKeyToken=b28c218413bdf563' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

  6. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    24 May 2013
    Link to this post
    Hello Ajay,

    The error means that your project / solution is referencing to a specific version of the Telerik.Sitefinity assembly - for example if you have a custom module, custom class library or other 3rd party control which was built with the assemblies for Sitefinity 4.2, build 1733. In order to resolve the problem, you need to make sure that all projects within the Sitefinity solution are referencing the correct version of the dll. Another option would be to perform a bindingredirect:

    <runtime>
            <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
                <dependentAssembly>
                    <assemblyIdentity name="Telerik.Sitefinity" publicKeyToken="b28c218413bdf563"/>
                    <bindingRedirect oldVersion="4.2.1733.0" newVersion="4.4.2117.0"/>
                </dependentAssembly>
    <dependentAssembly>
            </assemblyBinding>
        </runtime>


    Regards,
    Victor Velev
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Ajay
    Ajay avatar
    19 posts
    Registered:
    24 Aug 2012
    24 May 2013 in reply to Victor Velev
    Link to this post
    Hi,

    I have 6 other project in sitefinity web application .

    I can update (sitefinity web application) but how to update 6 other project  Telerik.Sitefinity  dll .
  8. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    24 May 2013
    Link to this post
    Hello Ajay,

    If any of the other projects is referencing the old 4.2 build 1733 dll, you will need to remove the reference using Visual Studio, add new reference to the 4.4 assembly and build the projects within the solution.

    Regards,
    Victor Velev
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  9. Ajay
    Ajay avatar
    19 posts
    Registered:
    24 Aug 2012
    24 May 2013 in reply to Victor Velev
    Link to this post
    dear sir,
    i am follow your step there is one more error

    Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.

    please help
  10. Stefani Tacheva
    Stefani Tacheva avatar
    718 posts
    Registered:
    21 Nov 2016
    24 May 2013
    Link to this post
    Hi Ajay,

    The LoaderExceptions error can be thrown if you have mismatching references for example, when you rebuilt the project - this action removes the dlls from the bin folder and results into the exception you are getting.

    Could you please check the following article which contain information which might be helpful to you ( if you have not read it already ): Also you can try cleaning up your solution and build it again.

    http://www.sitefinity.com/devnet/forums/sitefinity-4-x/bugs-issues/server-error-in-firstproject-application-unable-to-load-one-or-more-of-the-requested-types-retrieve-the-loaderexceptions-property-for-more-information.aspx


    Regards,
    Stefani Tacheva
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  11. Lourdu
    Lourdu avatar
    7 posts
    Registered:
    06 Sep 2012
    25 May 2013 in reply to Stefani Tacheva
    Link to this post
    hi,

    i Ihave fixed above issue.

    there is a problem come 

    when we open site is dev then asked for ( To run Sitefinity CMS you need to activate a valid license)

    tell me how to fixed
    please see  attachment 

  12. Ajay
    Ajay avatar
    19 posts
    Registered:
    24 Aug 2012
    25 May 2013 in reply to Stefani Tacheva
    Link to this post


    hi,

    i Ihave fixed above issue.

    there is a problem come 

    when we open site is dev then asked for ( To run Sitefinity CMS you need to activate a valid license)

    tell me how to fixed
    please see  attachment 
    2 posts
    Registered:
    06 Sep 2012
    11 minutes ago in reply to Stefani Tacheva
    Link to this post
    hi,

    i Ihave fixed above issue.

    there is a problem come 

    when we open site is dev then asked for ( To run Sitefinity CMS you need to activate a valid license)

    tell me how to fixed
    please see  attachment 
    2 posts
    Registered:
    06 Sep 2012
    11 minutes ago in reply to Stefani Tacheva
    Link to this post
    hi,

    i Ihave fixed above issue.

    there is a problem come 

    when we open site is dev then asked for ( To run Sitefinity CMS you need to activate a valid license)

    tell me how to fixed
    please see  attachment 
  13. Arno
    Arno avatar
    249 posts
    Registered:
    08 Sep 2010
    25 May 2013
    Link to this post
    Hi Ajay,

    This is not an error. Just fill out your Sitefinity login or point to a license file that you can download from your account.
  14. Lourdu
    Lourdu avatar
    7 posts
    Registered:
    06 Sep 2012
    25 May 2013 in reply to Arno
    Link to this post
    .
  15. Ajay
    Ajay avatar
    19 posts
    Registered:
    24 Aug 2012
    25 May 2013 in reply to Arno
    Link to this post
    dear sir,

    I have  login with Sitefinity  account 

    and point to a license file that you can download

    it say that invalid licence.

     

    I have sitefinity account . I am unable to find licenses key. Please help 
    me how can I find it.

    Thanks
  16. Arno
    Arno avatar
    249 posts
    Registered:
    08 Sep 2010
    25 May 2013 in reply to Ajay
    Link to this post
    If you go here you can download your license files.
  17. Ajay
    Ajay avatar
    19 posts
    Registered:
    24 Aug 2012
    03 Jul 2013
    Link to this post
    hi arno ,

    Conversion from 4.2 to 4.4 is success. thanks

    Now i want to converting it from 4.4 to 5.0



    my question is  

    using Telerik.OpenAccess;
    using Telerik.OpenAccess.Metadata.Fluent;
    using Telerik.OpenAccess.Metadata.Fluent.Advanced;

    not find inside 

    Telerik.OpenAccess.40.Extensions.dll

    but find inside Telerik.OpenAccess.35.Extensions.

    i want to convvert 4.4 to 5.0 then it need to use Telerik.OpenAccess.40.Extensions.dll.

     error
    The type or namespace name 'Fluent' does not exist in the namespace 'Telerik.OpenAccess.Metadata' (are you missing an assembly reference?)

    The type or namespace name 'MappingConfiguration' could not be found (Are you missing a using directive or an assembly reference?)

    Please tell me how to fixed.
  18. Stefani Tacheva
    Stefani Tacheva avatar
    718 posts
    Registered:
    21 Nov 2016
    05 Jul 2013
    Link to this post
    Hi,

    In Sitefinity 5.0 we are using the following OpenAccess dlls:
    Telerik.OpenAccess
    Telerik.OpenAccess.35.Extensions
    Telerik.OpenAccess.Config
    Telerik.OpenAccess.MySql.Data
    Telerik.OpenAccess.Runtime
    Telerik.OpenAccess.Web

    Note that in Sitefinity 6.0 we are using: Telerik.OpenAccess.35.Extensions as well, not Telerik.OpenAccess.40.Extensions

    Please use the Telerik.OpenAccess.35.Extensions dll.

    Regards,
    Stefani Tacheva
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
18 posts, 0 answered