1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Upgrade to 4.x from 3.7

Upgrade to 4.x from 3.7

5 posts, 0 answered
  1. Eric Krauska
    Eric Krauska avatar
    5 posts
    Registered:
    14 Dec 2007
    06 Oct 2011
    Link to this post
    Is there a clear and supported upgrade path to 4.x from 3.7 available yet? 
  2. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    06 Oct 2011
    Link to this post
    Dear Eric

    As far as I know you have to upgrade 3.7 to the .net 4.0 version first. I guess SP4 would make sense. After that it seems you can crate a new site and use the module on the dashboard.

    Never tried it.
    Some stuff sure wont work like modules that don't exist in 4.x yet, custom code that would have to be looked after.

    http://www.sitefinity.com/devnet/forums/sitefinity-4-x/migrating-from-3-to-4/sitefinity-3-7-to-4-2-or-net-3-5-to-4.aspx

    http://www.sitefinity.com/devnet/forums/sitefinity-4-x/migrating-from-3-to-4/upgrading-3-7-net-3-5-to-4-2.aspx

    There is also a special forum for these questions.

    I would open a support ticket.

    Also Telerik is very interested in demo projects to test the upgrade process. Maybe in your ticket you can ask them if they want your project to test, so they could kind of tell you how much trouble you might run into.

    Regards Markus
  3. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    06 Oct 2011
    Link to this post
    Hello Eric Krauska,

    You need to move your 3.7 SP4 project to .NET 4.0, by applying the patch which you can find in your downloads page. After you make sure your project starts using .NET 4.0 you can create a new 4.2 Project, which contains the migration module. Then you need to follow the on-screen instructions.

    You can follow my post in this thread you can find useful information.

    Basically you need a fresh copy of Sitefinity 4.2 to complete the process. Once you have it set click on the Migration tool and follow the on - screen instructions.

    Regards,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  4. Chris
    Chris avatar
    7 posts
    Registered:
    29 Jun 2010
    06 Oct 2011
    Link to this post
    in my thread at http://www.sitefinity.com/devnet/forums/sitefinity-4-x/migrating-from-3-to-4/yet-another-migrating-3-7-to-4-2-question.aspx#1829482 I was told that I did not need to upgrade my project to .net 4, as the migration module would handle the conversion showing that it supports 3.x .net 3.5. I was under the impression that it's 3.7 sp3 or higher. Can you confirm?
  5. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    07 Oct 2011
    Link to this post
    Hi Chris,

    If you are migrating your project using 4.2 SP1 you need to be using .NET 3.5 or .NET 4.0. However your website needs to be 3.7 SP4. If you use earlier versions please download the patch ( it can be found in your downloads page ) and apply it.

    Greetings,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
5 posts, 0 answered