1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Upgrade to Sitefinity 4.4 , but my customer module can not find the resource, error 404

Upgrade to Sitefinity 4.4 , but my customer module can not find the resource, error 404

4 posts, 0 answered
  1. Wei
    Wei avatar
    6 posts
    Registered:
    23 Nov 2011
    04 Jan 2012
    Link to this post
    when i Upgrade to Sitefinity 4.4 ,  my three customer modules created in sitefinity 4.1 can not find the resource, error 404. 

    Physical PathC:\inetpub\wwwroot\Sitefinity\Content\SitefinityModule.ManageDevices
    Logon MethodSitefinity
    Logon Useradmin




    Server Error in '/' Application.

    The resource cannot be found.

    Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly. 

    Requested URL: /Sitefinity/Content/SitefinityModule.ManageDevices


    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.272



  2. Grace Hallwachs
    Grace Hallwachs avatar
    144 posts
    Registered:
    03 Nov 2014
    10 Jan 2012
    Link to this post
    Hello,

    Can you confirm all the necessary assemblies were added to the project after the upgrade? The assemblies needed are the Sitefinity 4.4 assemblies all Telerik.Sitefinity.(Resouces, Model, Utilities) and OpenAccess assemblies. This is because Sitefinity 4.4 uses different version of OpenAccess than Sitefinity 4.1.

    Greetings,
    Grace Hallwachs
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Wei
    Wei avatar
    6 posts
    Registered:
    23 Nov 2011
    10 Jan 2012
    Link to this post
    my module project added this assemblies:
    Telerik.OpenAccess   
    Telerik.OpenAccess.35.Extensions
    Telerik.OpenAccess.40.Extensions
    Telerik.Sitefinity
    Telerik.Sitefinity.Model
    Telerik.Sitefinity.Resources
    Telerik.Sitefinity.Utilities
    Telerik.Web.Design
    Telerik.Web.UI

    and my customer module project has  "reference paths":   C:\Program Files\Telerik\Sitefinity 4.4\SDK\Content\Common\Dependencies\

    all the  reference dll file's path properties is "C:\Program Files\Telerik\Sitefinity 4.4\SDK\Content\Common\Dependencies\***.dll"

    Does this set is right?
    I use this setup to build my customer module. but also has the same error.



    Thanks.
  4. Grace Hallwachs
    Grace Hallwachs avatar
    144 posts
    Registered:
    03 Nov 2014
    21 Jan 2012
    Link to this post
    Hello Wei,

    Can you double check your paths and confirm you have all the necessary reference paths in your modules? You may need to resolve any references you do not have by going to Visual Studio -> Right-click on the references -> Organize usings and choose the appropriate option.

    All the best,
    Grace Hallwachs
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
4 posts, 0 answered