+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Using FormAssembly.com Forms with SiteFinity

Using FormAssembly.com Forms with SiteFinity

2 posts, 0 answered
  1. Erich
    Erich avatar
    1 posts
    Registered:
    05 Feb 2013
    05 Feb 2013
    Link to this post
    I'm working with a client whose site was built with sitefinity. We want to add forms to the site which are generated by FormAssembly.com. FormAssembly allows the forms to do a direct insert into the SalesForce database which is why we use it and not the sitefinity forms. 

    I've created the form in FormAssembly and copied the generated code into sitefinity. The form displays correctly but doesn't doesn't seem to execute the javascript. I thought it was working previously (starting to wonder if I imagined it) but even the simplest form doesn't work now. 

    The same code works fine in a Joomla site and it works fine as a stand-alone html page. 

    I'm new to sitefinity. Are there issues with running scripts in the HTML of a page? 

    Any thoughts on what could be going on?

    Any help is much appreciated. 

    Thanks

    Erich
  2. Pavel Benov
    Pavel Benov avatar
    341 posts
    Registered:
    14 Mar 2016
    07 Feb 2013
    Link to this post
    Hi Erich,

    The most probable reason for having troubles with the form is that in Sitefinity (as an Asp.Net application) you can have only one form on the page, and this form is by default in any page - see the following KB article.

    This problem has been discussed before in our Forums, so I believe you will find the following threads helpful:

     
    Regards,
    Pavel Benov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered