+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / can't upgrade to sp 4

can't upgrade to sp 4

4 posts, 0 answered
  1. Inna
    Inna avatar
    97 posts
    Registered:
    08 Jun 2012
    04 Feb 2011
    Link to this post
    hello,
    when i install sp4 - copy the bin folder the site goes down, and i see this error:
    please help!

    Server Error in '/' Application.

    Could not load file or assembly 'Telerik.Blogs.Data' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.BadImageFormatException: Could not load file or assembly 'Telerik.Blogs.Data' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'Telerik.Blogs.Data' could not be loaded.

    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

    Stack Trace:

    [BadImageFormatException: Could not load file or assembly 'Telerik.Blogs.Data' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.]
    System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection) +0
    System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection) +43
    System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +127
    System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +142
    System.Reflection.Assembly.Load(String assemblyString) +28
    System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +46

    [ConfigurationErrorsException: Could not load file or assembly 'Telerik.Blogs.Data' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.]
    System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +613
    System.Web.Configuration.CompilationSection.LoadAllAssembliesFromAppDomainBinDirectory() +203
    System.Web.Configuration.CompilationSection.LoadAssembly(AssemblyInfo ai) +105
    System.Web.Compilation.BuildManager.GetReferencedAssemblies(CompilationSection compConfig) +178
    System.Web.Compilation.BuildProvidersCompiler..ctor(VirtualPath configPath, Boolean supportLocalization, String outputAssemblyName) +54
    System.Web.Compilation.CodeDirectoryCompiler.GetCodeDirectoryAssembly(VirtualPath virtualDir, CodeDirectoryType dirType, String assemblyName, StringSet excludedSubdirectories, Boolean isDirectoryAllowed) +600
    System.Web.Compilation.BuildManager.CompileCodeDirectory(VirtualPath virtualDir, CodeDirectoryType dirType, String assemblyName, StringSet excludedSubdirectories) +128
    System.Web.Compilation.BuildManager.CompileCodeDirectories() +265
    System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled() +320

    [HttpException (0x80004005): Could not load file or assembly 'Telerik.Blogs.Data' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.]
    System.Web.Compilation.BuildManager.ReportTopLevelCompilationException() +58
    System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled() +512
    System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters) +729

    [HttpException (0x80004005): Could not load file or assembly 'Telerik.Blogs.Data' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.]
    System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +8897503
    System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +85
    System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +259


    Version Information: Microsoft .NET Framework Version:2.0.50727.4206; ASP.NET Version:2.0.50727.4209



    When I refresh the webpage with the error above, it changes to this message:

    Server Error in '/' Application.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Could not load file or assembly 'Telerik.Framework' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.

    Source Error:

    Line 186:      </eventMappings>
    Line 187:      <providers>
    Line 188:        <add name="Simple Web Event Provider" type="Telerik.Utilities.TextFileWebEventProvider,Telerik.Framework" logFileName="~/App_Data/sitefinity.log" />
    Line 189:        <add name="Simple Web Buffered Event Provider" type="Telerik.Utilities.BufferedTextFileWebEventProvider,Telerik.Framework" bufferMode="Notification" logFileName="~/App_Data/sitefinity.log" />
    Line 190:        <add name="Code Benchmark Provider" type="Telerik.Utilities.CodeBenchmarkTextFileProvider,Telerik.Framework" enabled="False" logFileName="~/App_Data/performance.log" />

    Source File: D:\Annapolis\web.config    Line: 188

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'Telerik.Framework' could not be loaded.

    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
    


    Version Information: Microsoft .NET Framework Version:2.0.50727.4206; ASP.NET Version:2.0.50727.4209



    I don't understand what's going on. I was following the Upgrade Instructions item-by-item. What did I do wrong?

    thank you

    inna
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    07 Feb 2011
    Link to this post
    Hi Inna,

    Please send us your project and database. We will see what is wrong with the upgrade and upgrade the site locally. Then we will send you back the upgraded project.

    Kind regards,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Inna
    Inna avatar
    97 posts
    Registered:
    08 Jun 2012
    07 Feb 2011
    Link to this post
    here is the site and the database. i upgraded all the folders and files from sp 4 except "bin" folder. when i try to upgrade the "bin" that's what sends these error messages and takes the site down.

    i also lost a custom style - it was configured to be an option in the drop-down of the visual editor. what file should i put back to restore this functionality?

    thank you.
  4. Inna
    Inna avatar
    97 posts
    Registered:
    08 Jun 2012
    07 Feb 2011
    Link to this post
    Can't attach the zip file with the site - getting this error:

    File is not of correct type. Try again. 2MB: the max total size of all attached files
    Allowed extensions: .gif, .jpg, .jpeg, .png
Register for webinar
4 posts, 0 answered