+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Could not resolve type for tag "telerik:WorkflowMenu". Make sure the proper namespace is registered.

Could not resolve type for tag "telerik:WorkflowMenu". Make sure the proper namespace is registered.

3 posts, 1 answered
  1. Andrew
    Andrew avatar
    202 posts
    Registered:
    05 Jun 2009
    07 Jul 2009
    Link to this post
    I am trying to get the products module from this blog: http://blogs.sitefinity.com/Ivan/Posts/09-03-21/Products_module_Reusing_Views.aspx. To work in my site.

    When trying to create a new product i get the error:
    "Could not resolve type for tag "telerik:WorkflowMenu". Make sure the proper namespace is registered."

    The actual product item is created. I just can't view it.

    Having found the line in the line in the templates. (Resources/controlTemplates/backend/ProducPreviewView.ascx)
    I can see that the system is not recognising the tag:
    <telerik:WorkflowMenu ID="workflowMenu" runat="server" />

    I follwed the instructions from the blog on how to set it up.
    It does compile.

    Any ideas what the problem could be?

    Andrew
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    07 Jul 2009
    Link to this post
    Hi Andrew,

    Thank you for using our services.

    If you are trying to import the products module in Sitefinity Community  Edition this error will appear, since workflow is not included in that edition. If you take a look at the line which gives you the error, you will see that above and bellow lines look like this:

    <!-- BEGIN EXCLUDE FOR COMMUNITY --> 
           <telerik:WorkflowMenu ID="workflowMenu" runat="server" /> 
    <!-- END EXCLUDE FOR COMMUNITY --> 

    If you are using Sitefinity Community edition you will have to remove workflow related tags from the product module views. Take a look at the .ascx files, find the "Exclude for Community" comments and remove/comment those portions of code surrounded by them.

    Regards,
    Rado
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
    Answered
  3. Andrew
    Andrew avatar
    202 posts
    Registered:
    05 Jun 2009
    07 Jul 2009
    Link to this post

    Ahh... of course. How silly of me.
    I installed the module on my old testing page.
    I have commented the appropriate lines out and it does in fact work.

    Thanks for your help.

Register for webinar
3 posts, 1 answered