+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Creating Pages after upgrading to SP4

Creating Pages after upgrading to SP4

4 posts, 0 answered
  1. Karl
    Karl avatar
    45 posts
    Registered:
    18 Jun 2009
    03 Feb 2011
    Link to this post
    Hi,
    We have upgraded to Sitefinity 3.7 SP4 .Net4 version, everything works fine apart from when we want to create a new page. As soon as we have to select a template we receive the javascript error 'OverlayUI is Undefined' Line 108 WebResources.axd. From that point we are unable to drag controls into content placeholders?
    Is there something we need to amend in IIS or the web config.

    Thanks.
    Karl.
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    03 Feb 2011
    Link to this post
    Hello Karl,

    I am not sure what the actual problem is here. Let's try the following

    1. Run the project through VS web server- this will eliminate issues that comes from IIS.
    2. If the problem persists, create a new template and try to open it. It is possible that there is something on your master page that breaks the backend page editor. Do not add scripts or css classes to the newly create template.
    3. When you use IIS, please make sure that the application pool that the upgraded project uses is set to use ASP.NET 4.0.

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Karl
    Karl avatar
    45 posts
    Registered:
    18 Jun 2009
    03 Feb 2011
    Link to this post
    Thanks for your reply.
    1) I compiled in VS2010 and received the following build error;

    The type or namespace name 'ScriptManager' does not exist in the namespace 'System.Web.UI' (are you missing an assembly reference?) C:\Users\Websites\Intranet\App_Master\Default.master


    2) After uploading a new masterpage, I again got the same error but referencing the scriptmanager in the template I had just uploaded

    3) The application pool is definately set to ASP.Net 4.0

    Any additional pointers would be helpful.
    Thanks.

  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    11 Feb 2011
    Link to this post
    Hi Karl,

    Please add the System.web.extension reference to the project  and also include the necessary references in the web.config

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
4 posts, 0 answered