+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Page doesn't appair in "Site Menu" control

Page doesn't appair in "Site Menu" control

4 posts, 0 answered
  1. Fabian
    Fabian avatar
    6 posts
    Registered:
    08 Dec 2008
    14 Jul 2011
    Link to this post
    Hi,

    I got a problem :
    I have a site and, I addes a new page on it.
    The problem is that the page doesn't appair in the "Site map" navigation control when I am on the live site and, I don't know why.

    Here is the tree to access this page :
    "All pages"
    -- > "Mon Compte"
    --> "Mes coordonnees"
    --> "Donnees agences"
    --> "Mot de passe oublie"

    The fact is that "Mes coordonnees" and "Donnees agences" can be seen on the live site menu but not "Mot de passe oublie".

    I check the "Show in navigation" radio button and this otpion is enable.
    "Mon compte" page have "anonymous access" allowed as well as "Mot de passe oublie".
    So I think that it can be seen without cheking the permissions of the users.
    But, I also check the permissions for my roles and I enable the "View" permission for all the roles I have.

    So, i don't understand what I am doing wrong ... :-(

    Hope someone can help me.

    Thanks

    Fabian
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    19 Jul 2011
    Link to this post
    Hi Fabian,

    Can you please let us know if the page has at least one published version? If the page does not have published versions you will not be able to see it in the menu.

    Best wishes,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Fabian
    Fabian avatar
    6 posts
    Registered:
    08 Dec 2008
    20 Jul 2011
    Link to this post
    Hello,

    It seems it work now and I didn't change anything.

    Is it possible that it take some times between the publishing of the page in the cmsdesk and the real publication on the live site ?

    Thanks anyway

    Fabian
  4. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    25 Jul 2011
    Link to this post
    Hi Fabian,

    If your site is in single server scenario caching will not be an issue as the page cache is cleared when the page is published. If your site is in NLB you must set cache dependencies to be stored InDatabase so that it can be properly read on all servers.

    All the best,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
4 posts, 0 answered