Try Now
More in this section

Forums / General Discussions / Sitefinity 3.7 - Admin Default lanuguage

Sitefinity 3.7 - Admin Default lanuguage

2 posts, 0 answered
  1. v
    v avatar
    27 posts
    12 Aug 2009
    05 Nov 2009
    Link to this post

    When the admin is trying to login by default it should redirect to
    but it's trying to recirect

    below steps i followed. is there any other steps to follow up.
            <localization defaultProvider="Sitefinity" autoSetClientLanguage="false" persistenceMode="PathPrefix" defaultCulture="ar" allowSpecificCultures="True" cultures="ar,en">
                    <add name="Sitefinity" type="Telerik.Localization.Data.DefaultProvider, Telerik.Localization.Data" connectionStringName="DefaultConnection"/>

    Thanks in advance

  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    01 Feb 2016
    05 Nov 2009
    Link to this post
    Hi v,

    Thank you for using our services.

    Unfortunately we do experience some issues with this. If you have had enabled localization on an earlier stage and set default culture the redirect works. However if you have enabled localization and change default language on a later stage it will keep loading the original culture interface on login. If you set default culture ar on a fresh project the redirect will work.

    We are not able however to fix this in the upcoming SP. So the only available workaround would be to either to set the return url of the login form in the ~/Sitefinity/Login.aspx to be the desired URL:
    <asp:Login ID="Login1" runat="server" DestinationPageUrl="http://localhost:8080/ar/Sitefinity/Admin/Default.aspx">

    Note you will have to edit this once you go to production. Or each user can set their preferred culture on the My Preferences page (see attached image).

    Kind regards,
    Radoslav Georgiev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
2 posts, 0 answered