+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Sitefinity on Mosso

Sitefinity on Mosso

5 posts, 0 answered
  1. Laura
    Laura avatar
    311 posts
    Registered:
    25 Feb 2008
    03 Aug 2009
    Link to this post
    We have our sites hosted on Mosso (Rackspace Cloud).

    They are moving to a Medium Trust environment next week. That day - we will find out if there are any problems with our sites...  some are in the orginal Full Trust environment....  Just wondering if anyone else is using Mosso with Sitefinity and what other problems they are having - like a very very slow first time load of the site as well.....

    Thanks.
  2. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    04 Aug 2009
    Link to this post
    Hi Laura,

    I can provide you with some feedback on this.

    The first thing you will need to check is if your application is configured correctly to run in Medium trust. Please check the User Manual -> Working in Medium Trust for this. 

    The second thing, please check that all section names defined in the web.config file have requirePermission="False" :
     <sectionGroup name="telerik"
          <section name="dataAccess" type="Telerik.DataAccess.Configuration.SectionHandler, Telerik.DataAccess"  
           requirePermission="false"/> 

    If everything from the above is set, you should face no problems. 

    Best wishes,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the newTelerik Support Portal.
    Check out the tipsfor optimizing your support resource searches.
  3. David
    David  avatar
    78 posts
    Registered:
    29 Dec 2008
    19 Aug 2009
    Link to this post
    Hi Laura,

      I follow the instructions from SiteFinity docs to set up my web.config to a medium trust.  
    I tested my site with the link Mosso provided me, and discover if you place trust level = medium in your web.config file the site will break.  Leave that line out, because Mosso is a modified Medium Trust.  My site work fine in medium trust after removing that line.

    The sitefinity site drops out the server memory after so many minutes pass by with out a visitor.  To keep it memory do the following.

    Steps to fix the slow start up:
    1. Log into Mosso/Rackspace panel for your website.
    2. Select the Feature tag for your site
    3.  Under Scheduled Tasks, Add New Task
    4. Task Name field: Keep Alive
    5.  Email address for the task results, note I use my yahoo account and send the email to spam.
    6.  Set Command Language to http
    7.  Set Command to Run to you home page of your site
    8.  Set Repeat by to Minute
    9.  Set Frequency to Every 15 mins.

    This will increase you site load time.  You can adjust the frequency until it loads quick every time. 

    Good Luck
    David
    www.saludalabs.com
  4. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    19 Aug 2009
    Link to this post
    Hi David ,

    Thank you for the extensive feedback! This will surely help to the people that want their sites hosted on Mosso. You account is updated for the help!

    Regards,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the newTelerik Support Portal.
    Check out the tipsfor optimizing your support resource searches.
  5. Laura
    Laura avatar
    311 posts
    Registered:
    25 Feb 2008
    20 Aug 2009
    Link to this post

    Thank you to everyone's feedback on this.

    Thank you very much to David on your extensive feedback and solution. That is what makes these forums great!

     

    --Laura

Register for webinar
5 posts, 0 answered