+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / unable to upload controls

unable to upload controls

6 posts, 0 answered
  1. NuToSitefinity
    NuToSitefinity avatar
    140 posts
    Registered:
    01 Sep 2010
    12 Apr 2011
    Link to this post
    We move our site to a testing server and now we are unable to upload controls to the toolbox. When we try to upload a new control we get 'access denied to sitename\web.config' and the file has the same ID's and permission to it as my development server. What could I be missing on this server?
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    12 Apr 2011
    Link to this post
    Hello NuToSitefinity,

    Most probably the account that you use to run the ASP.NET process does not have write permissions over the web.config file. When you upload a new control this writes a new line inside <toolboxControls> in the web.config. Please check the account under which you run your application pool and make sure that it has proper permissions over the website.

    Best wishes,
    Ivan Dimitrov
    the Telerik team

  3. NuToSitefinity
    NuToSitefinity avatar
    140 posts
    Registered:
    01 Sep 2010
    13 Apr 2011
    Link to this post
    I did that actually, i gave the ID full access and no such luck still
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    13 Apr 2011
    Link to this post
    Hi NuToSitefinity,

    Can you share the error you are getting?

    Kind regards,
    Ivan Dimitrov
    the Telerik team

  5. NuToSitefinity
    NuToSitefinity avatar
    140 posts
    Registered:
    01 Sep 2010
    13 Apr 2011
    Link to this post
    An error occurred loading a configuration file: Access to the path
    'D:\Inetpub\wwwroot\webSite\fyabn5vk.tmp' is denied. (D:\Inetpub\wwwroot\webSite\web.config)


    and the folder has the same permissions as it does on my development server
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    13 Apr 2011
    Link to this post
    Hi NuToSitefinity,

    This is a general ASP.NET error related to inefficient permissions. Since this works fine on the other machine you have, the problem is in the permissions set over the new host and the process that runs ASP.NET. This applies to each other web application - reading and writing XML files .

    All the best,
    Ivan Dimitrov
    the Telerik team

Register for webinar
6 posts, 0 answered