+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Upgrade from 3.5

Upgrade from 3.5

12 posts, 0 answered
  1. mcpdinkansas
    mcpdinkansas avatar
    102 posts
    Registered:
    22 Mar 2007
    04 Nov 2009
    Link to this post
    How would i go about upgrading 3.5 to the latest 3.7 SP2?

    -Cody
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    04 Nov 2009
    Link to this post
    Hi mcpdinkansas,

    Please tale a look at our Upgrade Instructions.

    Greetings,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. mcpdinkansas
    mcpdinkansas avatar
    102 posts
    Registered:
    22 Mar 2007
    04 Nov 2009
    Link to this post
    I should have been more detailed. Do I need to install every update from 3.5 to 3.7 SP2 or will simply installing 3.7 SP2 cover every other Service Pack and version I don't have?

    Also, where do I go to get the upgrade? Does it require a new purchase?

    -Cody
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    04 Nov 2009
    Link to this post
    Hi mcpdinkansas,

    Do I need to install every update from 3.5 to 3.7 SP2 or will simply installing 3.7 SP2 cover every other Service Pack and version I don't have?

    Installing the 3.7 SP1 directly should not be a problem( we do not have a SP2). There are customers that upgrades even from 3.1.

    Also, where do I go to get the upgrade? Does it require a new purchase?

    The patch does not require a new purchase. It should be able to obtain it from your account >> downloads section. Generally you should download the last official release if you do not see the patch.

    All the best,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  5. Colin Miller
    Colin Miller avatar
    5 posts
    Registered:
    19 Jan 2010
    16 Oct 2010
    Link to this post
    I am also upgrading from 3.5 to 3.7. My question is that the update instructions and the download dont seem to match.  The download is an EXE (sitefinity_3_7_2136_standard.exe) and apprears to be a full install?  The upgrade instructions refer to unZIPing a set of folder and files to be copied.  I dont want to break the site.

    Thanks 
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    17 Oct 2010
    Link to this post
    Hi Colin,

    You have to use one of the patches below



    Sincerely yours,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Colin Miller
    Colin Miller avatar
    5 posts
    Registered:
    19 Jan 2010
    19 Oct 2010
    Link to this post
    Hi,
        We tried the update and ended up with the following error - any ideas?

    Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

    Compiler Error Message: CS0234: The type or namespace name 'Linq' does not exist in the namespace 'System' (are you missing an assembly reference?)

    Source Error:

     

    Line 2:  using System.Collections.Specialized;
    Line 3:  using System.Configuration;
    Line 4:  using System.Linq;
    Line 5:  using Nolics.ORMapper.Base;
    Line 6:  using Telerik.DataAccess.AspnetProviders;
     

    Source File: d:\domains\NETMFBETA.COM\SBA\App_Code\Membership\RoleProvider.cs 
    .
  8. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    19 Oct 2010
    Link to this post
    Hi Colin Miller,

    Make sure that you have reference to System.Core.dll and you target  .NET3.5.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  9. Colin Miller
    Colin Miller avatar
    5 posts
    Registered:
    19 Jan 2010
    19 Oct 2010
    Link to this post
    Hi Ivan,
        Our site has a .NET 2.0 application pool so we used that patch.  Are you saying that we need to use the 3.5 patch instead?
    Thanks
  10. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    19 Oct 2010
    Link to this post
    Hello Colin,

    If you are using LINQ in your custom class RoleProvider.cs you need to target .NET 3.5, otherwise you can remove the reference and use .NET 2.0

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  11. Colin Miller
    Colin Miller avatar
    5 posts
    Registered:
    19 Jan 2010
    19 Oct 2010
    Link to this post
    Our hosting company swears we are running .NET 2.0 on the site.  However, the running Sitefinity version has the LINQ reference in it.  I assume the .NET libraries are not part of the Sitfinity install?  Any ideas are appreciated.  I am a little stuck here.  :-)
  12. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    19 Oct 2010
    Link to this post
    Hello Colin,

    By default we are not including these reference, so you have added them in your custom code. If you target .NET 2.0, please remove the reference to LINQ and modify your code if necessary.

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
12 posts, 0 answered