+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / URL Rewriting only works Locally

URL Rewriting only works Locally

6 posts, 0 answered
  1. mcpdinkansas
    mcpdinkansas avatar
    102 posts
    Registered:
    22 Mar 2007
    05 Nov 2009
    Link to this post
    I have setup url rewriting with the Sitefinity provided rewriting. It works perfectly locally but when on our development server it does not work.

    I copied the exact same web.config variables from local to the development version, but I get a 404 when accessing my rewrite url.

    Is there any IIS settings that need to be in place for this to work? Just stuck, local = works and dev = does not work, even though both web.config are exactly the same.

    Thanks
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    06 Nov 2009
    Link to this post
    Hi mcpdinkansas,

    Compare the HandlerMappings between your IIS servers. There could be difference in the mappings you use.

    All the best,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. Lee
    Lee avatar
    13 posts
    Registered:
    15 Aug 2008
    20 Jul 2010
    Link to this post
    Hi,

    I'm having a similar problem, my site is hosted with 123-reg, the rewrite works fine locally and the web.config has been copied to the live server but I get a 404 on the rewrite.

    <rule>
      <url>/pitches/(.*)</url>
      <rewrite>~/pitches/pitch-details.aspx?name=$1</rewrite>
    </rule>
    <rule>
      <url>/teams/(.*)</url>
      <rewrite>~/teams/team-details.aspx?name=$1</rewrite>
    </rule>

    The website is http://cdsfl.co.uk/ and the page it is looking for http://cdsfl.co.uk/pitches/Test-Pitch

    Any help would be greatly appreciated

    Thanks

    Lee
  4. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    22 Jul 2010
    Link to this post
    Hi Lee,

    Please make sure that you have added the CmsHttpUrlRewriteModule declaration in sytem.webServer/handlers configuration section in web.config.

    Regards,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Joe
    Joe avatar
    16 posts
    Registered:
    10 May 2010
    10 Jan 2011
    Link to this post
    Hi,

    Is there any resolution for this? I am having the same problems exactly.

    The main difference I can point out to is that I am trying to deploy on IIS 6.

    Locally, dev server works ok, but IIS 7 is redirecting to the actual url and the user can still see the url i am trying to re-write.
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    10 Jan 2011
    Link to this post
    Hi,

    Please make sure that you have registered the module properly. Please check this article -section  Registering the HTTP Module

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
6 posts, 0 answered