+1-888-365-2779
Try Now
More in this section

Forums / Migrating from 3.x to the latest Sitefinity version / Error migrating user's first name and last name

Error migrating user's first name and last name

3 posts, 1 answered
  1. Michael
    Michael avatar
    41 posts
    Registered:
    07 Nov 2013
    19 Nov 2013
    Link to this post
    Migrating from 3.7SP4 to 6.2.

    I'm running the migration tool to migrate users. It appears the users are migrated correctly, except for their first and last names (which are blank).

    On the migration dialog box, I get "The remote server returned an error: (500) Internal Server Error.". And "User profiles metadata for type "SitefinityProfile" coping...
    ""ERROR while migrating user profiles metadata."

    Wondering if anybody else came across this, and have an idea what could be wrong.

    Thanks,
    Michael
  2. Michael
    Michael avatar
    41 posts
    Registered:
    07 Nov 2013
    20 Nov 2013 in reply to Michael
    Link to this post
    I re-ran the migration tool with a small subset of my users and it was successful. Looks like there is one or more users who have metadata that cannot be migrated to 6.2; maybe because of invalid characters or the length being too long. Anyway, I haven't found a way to debug this. I have more than a thousand users, which make it really tricky to find out which user(s) fail. Any idea is much welcome.

    Thanks,
    Michael
  3. Michael
    Michael avatar
    41 posts
    Registered:
    07 Nov 2013
    02 Dec 2013
    Link to this post
    The issue was with a custom profile property of type string which was NULL in the database. After I changed the value to empty string, the migration was successful.

    In 3.7 database, telerik_UserMetaInfo table, "Text" column.

    It seems the migration tool does not handle NULL. It's also possible that there is no way to write a NULL value in the database through the UI, but that I can't be certain.

    Answered
3 posts, 1 answered