Try Now
More in this section

Forums / Migrating from 3.x to the latest Sitefinity version / Issue While deploying 3.7 Sitefinity Website to IIS7.

Issue While deploying 3.7 Sitefinity Website to IIS7.

2 posts, 0 answered
  1. Amit
    Amit avatar
    43 posts
    15 Nov 2012
    17 Nov 2012
    Link to this post
    I am very new to Sitefinity. Currently I created a website & deployed to IIS7 sucessfully. But I have to migrate a website developed in Sitefinity version 3.7.

    And I am having problems in deploying that site to IIS7, I searched & found the issue was in Web.Config, therefore I copied the web.Config from 5.2 project into the 3.7 project. But then I had following Error :
    Could not load file or assembly 'Microsoft.IdentityModel, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

    Previously (before changing the web.Config) I was having the 500 - Internal server error.

    the old Web.Config is attached in the attachments(coz, it was very large).


  2. Victor Velev
    Victor Velev avatar
    1345 posts
    06 Jul 2015
    20 Nov 2012
    Link to this post
    Hi Ashish,

    The error you are getting shows that you are missing an assembly from your references folder. However, the assembly by default comes with Sitefinity 5.x and is not required by a 3.7 project. Also the webconfig files of 3.x and 5.x are different, so you might be encountering other errors during the migration as well, therefore I would suggest to follow our upgrade instructions ( and set both sites locally ):


    The following blog post may also be useful, as it is a step-by-step guide through the migration process:


    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered