+1-888-365-2779
Try Now
More in this section

issue with assembly reference

8 posts, 0 answered
  1. mexner
    mexner avatar
    98 posts
    Registered:
    06 Apr 2006
    05 Jul 2011
    Link to this post
    Hello, I have downloaded the migration tool,
    http://www.sitefinity.com/marketplace/modules/sitefinity-migration-tool.aspx

    and have been following the instructions line by line. My issue is baffling - because it's such an easy step. From the documentation...

    • Expand the References node of this project and fix all the missing references by pointing them to DLL files in the /bin folder of your main 3.7 website project
    • Right-click on the MigrationExportService project and select Build. You will get a file named MigrationExportService.dll in MigrationExportService/bin/Debug


    My problem is, I have loaded all the new references to my old 3.7 project (3.7.2136.140:0). When I BUILD the MigrationExportService, I get 46 errors, all because the project can't find a reference to the assemblies I added. 

    Please see the attached video -- and provide any help you can.
    http://ascendio.com/downloads/issue_with_assembly_reference.swf

    Note:: I've tried using both .NET 3.5 and 4.0. My original project is in .NET 4.0

    Thanks!

  2. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    06 Jul 2011
    Link to this post
    Hi Mexner,

    Could you check the target .NET version of your MigrationExportService project and the version against which is compiled your Sitefinity 3.7 project. They should match - e.g. both should be 4.0. If your Sitefinity project is for .NET 4.0 then you can change the target version of your MigrationExportService to 4.0 (eventually by adding/removing a reference System.Web.ApplicationServices) and try again.

    Kind regards,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. mexner
    mexner avatar
    98 posts
    Registered:
    06 Apr 2006
    06 Jul 2011
    Link to this post
    Hi Lubomir,

    I have done that. My 3.7 site is .NET 4.0. When I attempt to target the migrationExportService to .NET 4.0 - it errors out (See screen shot).

    If I take my 3.7 SF site to .NET 3.5 and take the migrationExportService to .NET 3.5, i get the errors you saw in the video from my original post.

    Thanks,
  4. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    07 Jul 2011
    Link to this post
    Hi Mexner,

    Please build the tool against .NET 4.0. Add a reference to System.Web.ApplicationServices.

    Greetings,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. mexner
    mexner avatar
    98 posts
    Registered:
    06 Apr 2006
    07 Jul 2011
    Link to this post
    Thanks Lubomir, that worked.
  6. Samir Vaidya
    Samir Vaidya avatar
    261 posts
    Registered:
    05 Feb 2005
    10 Jul 2011
    Link to this post
    Will you be releasing a version of the Sitefinity v. 3.7 Migration Tool for both .Net 3.5 as well as .Net 4.0 due to the breaking changes in .Net 4.0 regarding assembly references?
  7. Samir Vaidya
    Samir Vaidya avatar
    261 posts
    Registered:
    05 Feb 2005
    10 Jul 2011
    Link to this post
    When I compiled my solution against .Net v. 4.0, I got the following build error messages:

    C:\Software\Telerik\280162_SitefinityMigration-0-7-Beta\MigrationExportService\MigrationExportService.cs(294,54): warning CS0618: 'Telerik.Cms.Web.UI.DynamicHyperLink' is obsolete: 'This control is obsolete. Please use Telerik.Cms.Engine.WebControls.DynamicHyperLink instead'
    C:\Software\Telerik\280162_SitefinityMigration-0-7-Beta\MigrationExportService\MigrationExportService.cs(301,25): warning CS0618: 'Telerik.Cms.Web.UI.DynamicHyperLink' is obsolete: 'This control is obsolete. Please use Telerik.Cms.Engine.WebControls.DynamicHyperLink instead'
    C:\Software\Telerik\280162_SitefinityMigration-0-7-Beta\MigrationExportService\MigrationExportService.cs(301,105): warning CS0618: 'Telerik.Cms.Web.UI.DynamicHyperLink' is obsolete: 'This control is obsolete. Please use Telerik.Cms.Engine.WebControls.DynamicHyperLink instead'

    Please advise.
  8. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    12 Jul 2011
    Link to this post
    Hi Samir Vaidya,

    These are not errors, these are warnings. You can safely ignore them.

    All the best,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
8 posts, 0 answered