+1-888-365-2779
Try Now
More in this section

migration from 3.7 to 5.0

4 posts, 0 answered
  1. Byzza
    Byzza avatar
    89 posts
    Registered:
    09 Jul 2007
    08 Mar 2012
    Link to this post

    So its taken me a while just to get 5.0 to connect to my 3.7 sp4 site, but I got there eventually.  But when I tried to do the first run at a migration I got a number of errors.
    First is that all my users failed.  I think its because they have a \ in the name because the are all domain accounts. eg

    Error occured during the migration of user BRADKEN\name.

    second is that all my templates failed

    Registering template "BH - Action"...
    Error: template BH - Action failed to migrate. The related master page ~/App_Master/BradHelp.master failed to load.

    and then because my templates failed the pages did also

    Error occurred during the migration of page QuickActions.
    Error: the template for page Assign Responsible Employee is not migrated. Please migrate the template first.


    Any Ideas?

    Oh and yes I have copied over all the files to the relative folders in the the 5.0 project





  2. Byzza
    Byzza avatar
    89 posts
    Registered:
    09 Jul 2007
    08 Mar 2012
    Link to this post
    I got the templates and pages work ok. I just had some script in the tempalte that wouldn't work in 5.0.  Removed it and it now works.

    So the only problem I have at the moment is the user list.


  3. Brijmohan Bhavsar
    Brijmohan Bhavsar avatar
    1 posts
    Registered:
    24 Sep 2009
    12 Apr 2012
    Link to this post
    Hi, Based on your experience can you please guide me on the steps needed to migrate from sitefinity 3.71 standard edition to 5.0 standard edition?

    Look forward to your response, thanks!
  4. SelAromDotNet
    SelAromDotNet avatar
    912 posts
    Registered:
    18 Jul 2012
    12 Apr 2012
    Link to this post
    I'm glad you got the templates worked out, thank you for the update!

    Regarding the users: are you using a custom membership provider in the 3.7 website? The migration module only supports importing using the default provider.

    If you are indeed using the default provider, can you attach the migration log and both sites' error logs to a support ticket so our migration team can further assist?
4 posts, 0 answered