Try Now
More in this section

Forums / Migrating from 3.x to the latest Sitefinity version / Ongoing Migration Problems from 3.7SP4 to 5.0

Ongoing Migration Problems from 3.7SP4 to 5.0

2 posts, 0 answered
  1. Chad
    Chad avatar
    9 posts
    04 Oct 2012
    05 Sep 2012
    Link to this post
    Hello All,

    I've been having nothing but problems attempting to migrate a site from 3.7SP4 to 5.0.  I have scoured the forums and read & watched all of the information Sitefinity posted that I can find.  I've set up my local environment as instructed, but at this point I'm running into 2 issues.

    First, I tried using the SF 5 Project Manager to set up the 3.7 site for migration.  The automated process did not work, so I followed the manual process.  After doing that, I attempted to browse to http://localhost:81/MigrationService.svc (where the svc was copied) and I see what is showing in attachment1.jpg.  According to the Josh Morales video, I'm supposed to see the service details. The log files reveal absolutely nothing about the error.  Searching the error on Microsoft Support and attempting their solutions do nothing.  Anyone ever encounter this and know of a solution?

    I decided to just leave it and try to move forward with the migration.  So, I set up a new blank SF 5.0 project as its own website in my local IIS.  That actually worked, so I was excited about that.  When I browsed to the local instance (http://localhost:82/Sitefinity), I saw the option to migrate a project from 3.7.  I enter the appropriate information and get the completely non-descript error seen in attachment2.jpg.  The log files reveal nothing about the error.  

    I suspect the migration doesn't work because there's a problem reading the .svc on the 3.7 site.  Who knows though.

    I'm using Windows 7 Pro with IIS 7.5. 

    I'm trying to migrate to 5.0 (instead of 5.1) because that's what I have a license for.  My support expired and I will not renew it until I know I can do this migration.

    If anyone has any ideas about this, it would be greatly appreciated. 
  2. SelAromDotNet
    SelAromDotNet avatar
    912 posts
    18 Jul 2012
    06 Sep 2012
    Link to this post
    Dustin, you are correct that the Migration Module in the new Sitefinity website connects through the Migration Service that you install in the old 3.7 website to import data. To get it working you'll definitely have to set up the migration service.

    You're probably already aware of our Sitefinity Migration Guide which links to a helpful post on preparing your site for migration: Migrating Sitefinity 3 to 4 Deep Dive: Preparation but I'm linking it here just in case for future visitors to this thread.

    Regarding your specific error, "the requested content appears to be script and will not be served by the static file handler" suggests you have a wildcard mapping that is attempting to serve this .svc file as a static resource (as if it was an image or a text file), but it actually needs to be handled by IIS (as if it were a web page) so it can be processed as a web service.

    take a look at this thread on stackoverflow which suggests a few options for making sure your IIS is setup to host services correctly.

    Hope this is helpful!
2 posts, 0 answered