+1-888-365-2779
Try Now
More in this section

Forums / Module Builder / Improper error message when property name does not exist

Improper error message when property name does not exist

3 posts, 0 answered
  1. Gary
    Gary avatar
    91 posts
    Registered:
    19 Jul 2007
    12 Mar 2013
    Link to this post

    Just to provide feedback on a small issue -- when calling DynamicContent.SetValue with an invalid property name string, the following error is displayed:

    #ResourceNotFound#:ErrorMessages:Type does not contain property with that name

    I don't think the "#ResourceNotFound#:ErrorMessages:" text was supposed to be included. Also, I'd like to suggest including the property name within the message text.

    Regards,

    Gary

     

  2. Majid
    Majid avatar
    10 posts
    Registered:
    17 Jan 2012
    30 Aug 2015 in reply to Gary
    Link to this post

    I am having the same exact issue but with the form submission.

    Garry can you explain what could possibly go wrong here ?

    how can i debug this ?

  3. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    23 Sep 2016
    12 Sep 2015
    Link to this post
    Hi,

    The exception message that is shown is incorrect. I have logged a bug regarding this in our portal. You can review it here:
    http://feedback.telerik.com/Project/153/Feedback/Details/169070-incorrect-exception-message-shown-when-using-setvalue

    The exception occurs when the field to set the value to, does not exist in the object Type.

    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
3 posts, 0 answered