+1-888-365-2779
Try Now
More in this section

Forums / Module Builder / Sitefinity 7 Related Data

Sitefinity 7 Related Data

4 posts, 0 answered
  1. James
    James avatar
    3 posts
    Registered:
    19 Nov 2013
    15 May 2014
    Link to this post

    Hi

    I'm trying to add a field to my Module that is of the type Related Data.  The problem is that the Data Type drop down is blank. I can't select anything and the field is required.

     Any help would be very appreciated.

     Thanks

  2. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    29 Sep 2016
    20 May 2014
    Link to this post
    Hello James,

    We have answered this issue in the support ticket of your colleague.

    For future references I would like to share the most probable reason for this issue. It is not correctly configured services section in the web.config. It should be as this snippet (under <configuration> node):
    <!-- SERVICE STACK-->
      <location path="RestApi">
        <system.web>
          <httpHandlers>
            <add path="*" type="ServiceStack.HttpHandlerFactory, ServiceStack" verb="*"/>
          </httpHandlers>
        </system.web>
        <!--Required for IIS7-->
        <system.webServer>
          <modules runAllManagedModulesForAllRequests="true"/>
          <validation validateIntegratedModeConfiguration="false" />
          <handlers>
            <remove name="ServiceStack.Factory" />
            <add path="*" name="ServiceStack.Factory" type="ServiceStack.HttpHandlerFactory, ServiceStack" verb="*" preCondition="integratedMode" resourceType="Unspecified" allowPathInfo="true" />
          </handlers>
        </system.webServer>
      </location>
      <!-- END SERVICE STACK-->


    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  3. Bishoy
    Bishoy avatar
    27 posts
    Registered:
    15 Aug 2013
    06 Aug 2014
    Link to this post

    Hey Nikola, I have a very Major issue with related data items and have raised it to be fixed ASAP however I'm working in a huge project and looking for any workaround 

    Now, In Multisites scenario, when I create a "related data items" field or" Related media", it asks me for the provider which is non-logical, it should work like in 7.1 the new multi child related items,  It automatically detects the current provider and apply it for this field.

    For Ex. Im working in implementing "related Data items" field for 2 diff countries, so its non-logical for an entity in country A to get its own images from Country B ... 

    Now When I set the provider to Country A Provider, it stops working when I switch to country B because no permissions granted for this image library.!

    Thank you
    Its Urgent

  4. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    29 Sep 2016
    06 Aug 2014
    Link to this post
    Hello Bishoy,

    We are currently working on fixing this issue, however, I cannot give an exact estimate in which internal build this is going to be fixed for. The bug regarding the related data in multisite scenario can be found here. There is a workaround for the issue, more information could be found on the following link from the SitefinityDevs Google+ group.

    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
4 posts, 0 answered