Try Now
More in this section

Forums / Security / Active Directory Problems

Active Directory Problems

2 posts, 0 answered
  1. Cameron
    Cameron avatar
    42 posts
    27 Jul 2009
    21 Apr 2010
    Link to this post
    Just when you think you've got it figured out:

    I've currently got an installation of Sitefinity working with Active Directory login on a development server inside our domain. When I move the site to our production server, which is in a DMZ, I can no longer authenticate using AD. I get a "Access Denied" error page on the line that includes

    type="Telerik.Security.ActiveDirectory.TelerikADMembershipProvider, Telerik.Security"/>

    If I try changing the LDAP server path, the error message changes to "Unable to establish secure connection with the server" so it appears I can connect to the LDAP server. I also ran Softerra's LDAP Browser on the production web server and I can connect to the LDAP server with no problem using the same credentials. In addition, a simple Microsoft example app called FormsAuthAD can do the lookup fine.

    The problem appears to be related to the Telerik ActiveDirectory provider somehow. I'm going crazy over this and could really use some help!


  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    01 Feb 2016
    22 Apr 2010
    Link to this post
    Hello Michael Buchsbaum,

    Thank you for using our services.

    Could you please try clearing browser cache, cookies and restarting the application. Sometimes there is an authentication ticket leftover which is causing problems like this one.

    Radoslav Georgiev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
2 posts, 0 answered