+1-888-365-2779
Try Now
More in this section

Forums / Security / Can't set role permissions for forum module

Can't set role permissions for forum module

3 posts, 1 answered
  1. Gawein
    Gawein avatar
    12 posts
    Registered:
    13 Oct 2009
    25 Feb 2010
    Link to this post
    Hello,

    I have set up a website with a Forum module and a Create User page. What I want is when a new user is created and assigned to the ForumUsers Role, this user can post, edit and delete threads.

    The problem is I can't set the correct permissions for the ForumUsers Role. When I set the permissions and save it, it says they are saved successfully. But when I return, the permissions I have checked are unchecked. The new user is also not able to post anything.

    What am I doing wrong?

    Thanks, Gawein
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    25 Feb 2010
    Link to this post
    Hi Gawein Heymans,

    If you set permissions from backend UI, please make sure that you have not set any permissions to everyone role. All other custom roles inherits permissions from everyone role. Let us know how it goes.

    Regards,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
    Answered
  3. Gawein
    Gawein avatar
    12 posts
    Registered:
    13 Oct 2009
    25 Feb 2010
    Link to this post
    Hi Ivan,

    That indeed do the trick. Thanks.

    Regards,
    Gawein
Register for webinar
3 posts, 1 answered