+1-888-365-2779
Try Now
More in this section

Forums / Security / Page Permission Problem

Page Permission Problem

5 posts, 0 answered
  1. Shawn Davis
    Shawn Davis avatar
    81 posts
    Registered:
    13 Oct 2012
    20 May 2010
    Link to this post
    I created a role called SiteManager that I assign to just a few people who I give permission to change content of the pages.  Problem is that these people can see the page but when they try to edit the page it is greyed out.  Even if I give them administrator privileges they still can't edit the pages.  When the user first creates their login they are assigned to a role that has only view rights, so I thought maybe that was overriding things and I unchecked their profile from that role and it still doesn't help.

    Any thoughts about what's going on?

    Thanks,
    Shawn
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    21 May 2010
    Link to this post
    Hi Shawn Davis,

    Check whether the same users are in a role which has Deny permission for pages. In this case - when a user belongs to two or more roles, deny permission has higher priority than allow.

    All the best,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Shawn Davis
    Shawn Davis avatar
    81 posts
    Registered:
    13 Oct 2012
    21 May 2010
    Link to this post
    Turns out that the default for page edit is Overlay mode which I guess I don't understand because it just greys everything out.  I had always used classic for the admin login and it obviously remembers that, but for a new user it went to Overlay which made it look like it was unavailable due to security permissions.

    Thanks for your help.
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    21 May 2010
    Link to this post
    Hi Shawn Davis,

    Just to let you know that you could set the pageEditorUIMode- Overlay and Classic in your web.config, so that you could set Classic as default value

    <cms defaultProvider="Sitefinity" pageExtension="" disabled="false" projectName="test" pageEditorUIMode="Classic">

    Most probably the div applies over the page because there are some spaces between opening and closing tags of the ContentPlaceHolder  controls declared in your master page. Try using short closing tag "/>" or remove the spaces.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. Shawn Davis
    Shawn Davis avatar
    81 posts
    Registered:
    13 Oct 2012
    21 May 2010
    Link to this post
    Thanks, that is nice to know and I'll check my tags.
Register for webinar
5 posts, 0 answered