+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / 404 Error on new project

404 Error on new project

6 posts, 0 answered
  1. Andrew
    Andrew avatar
    29 posts
    Registered:
    24 Jun 2009
    14 Jul 2009
    Link to this post
    I already have Sitefinity up and running, and a project working great locally.  I added a second project to my project manager, the folders created right, the application created in IIS, but when I click to edit the project I get a 404 error.  I'm running Vista x64 Ultimate.
  2. Andrew
    Andrew avatar
    29 posts
    Registered:
    24 Jun 2009
    14 Jul 2009
    Link to this post
    Here is my specific error:

    Detailed Error Information
    Module IIS Web Core
    Notification MapRequestHandler
    Handler StaticFile
    Error Code 0x80070002
    Requested URL http://localhost:80/MeritCompany
    Physical Path C:\Program Files (x86)\telerik\Sitefinity3.6 Community\ProjectManager\MeritCompany
    Logon Method Negotiate
    Logon User BigDaddy\Andrew

    Now that path doesn't exist, but there is a folder in the Websites folder called MeritCompany
  3. Andrew
    Andrew avatar
    29 posts
    Registered:
    24 Jun 2009
    14 Jul 2009
    Link to this post
    With further testing I also found that if I just created the "sample site" it also has the 404 error, but the first project I created is working beautifully.
  4. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    15 Jul 2009
    Link to this post
    Hello Andrew,

    Thank you for using our services.

    There seems to be some problem with how physical paths to your newly created websites are set in IIS. By default website physical paths are created in folder Websites as you have correctly noted that there is a folder with your project name there. I have tried to create several test projects through the Project Manager and they are all created C:\Program Files\telerik\Sitefinity3.6\WebSites\, where they should be. Also the physical paths set to those sites in the IIS Manager point to the correct location. Can you try to point the physical path of your newly created website in the IIS Manager. To do this select the MeritCompany web app in IIS Manager. On the right in the Actions panel select Basic Settings  and give the physical path like this: C:\Program Files (x86)\telerik\Sitefinity3.6 Community\WebSites\MeritCompany\.

    I hope this helps. If you have more questions feel free to contact us.

    All the best,
    Rado
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  5. Andrew
    Andrew avatar
    29 posts
    Registered:
    24 Jun 2009
    15 Jul 2009
    Link to this post
    That was my initial thought as well, however I checked the settings in IIS, and found that they appear to be correct, which was very strange indeed.  (Yes I have tried rebooting)

    Here is a screen shot of my IIS settings as they were created by Sitefinity.
    Settings in IIS
  6. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    16 Jul 2009
    Link to this post
    Hi Andrew,

    Thank you for getting back to me with a screen capture of your IIS settings.

    I have tested creating several websites with the community edition of Sitefinity and did not get the error. What I can suggest to you is to check if your IIS is set up to run in IIS 6.0 compatibility mode.  You can take a look at the following blog article, to see how to set up IIS 6.0 compatibility. Since you said that you are running Windows Vista x64, can you please check if your application pool is set up to enable 32-bit applications (see attached image).

    I hope that his helps. If you have more questions feel free to get back to us.

    Sincerely yours,
    Rado
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Register for webinar
6 posts, 0 answered